Went to dyno, HORRIBLE numbers HELP!!! - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 04-26-2008, 06:55 PM
COME ON...ONE TIME!!


 

Join Date: Sep 2007
Location: Fletcher, NC
Posts: 16,644
Thanks: 61
Thanked 53 Times in 52 Posts
Feedback Score: 0 reviews
Thumbs down Updated: Think I found my leak! Would this cause low oil pressure?

I put truck on a mustang dyno, and I have horrible results! Number one, I have a major oil leak, I leaked about a quart of oil over 5 pulls on the ground! I have to pull my turbo and check the pedistal. I think my lower o rings are shot.

Ok, the pulls. Stock tune was my best pull. no joke. My stock pull was 205 HP/385 TQ. Now, I know a mustang dyno will read lower cause of the weight of the rollers. But I thought I should have been above 400 TQ. But I do have 260k miles on the truck.

My street tune results were 199 HP/370 TQ Now I am not to smart, But I do know that those results are horrible!

My extreme tune results were 199 HP/ 351 TQ. Why are my numbers so low? Do I need to look for issues with fuel? My fuel pressure is 60 at all times. My engine oil pressure is LOW! I mean when its warmed up to operating temp its only 10-12 PSI on my aftermarket guage. When I floor it, it only goes to about 20 PSI. I know thats 1/3 of what it should be at WOT. I am gonna try to fix my oil leak by removing the turbo and pedistal and replacing o rings this week, and making sure the oil feed line is ok. My valley is dry, and I know the leak is on the backside of the engine.

I am pretty sure if my engine oil pressure is low, then my HPOP is not getting what it needs, which means my injectors arent seeing the oil pressure and volume they need. Am I correct?

So, what do i need to start to look for? Bad injectors? truck seems to run fine. Guys at the dyno said it sounded healthy and were very impressed with stock HP numbers. I am Pissed off at my results and I wanna fix em. I am embarassed to reveal these nnumbers, but i know you guys will help. thanks!!!!!

Last edited by HVAC SuperTech; 04-30-2008 at 03:28 PM.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 04-26-2008, 06:58 PM
Compression Ignition Addict
 

Join Date: Mar 2007
Posts: 1,416
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
yeah you have problems. you should be making way more hp than that
Reply With Quote Quick reply to this message
  #3  
Old 04-26-2008, 07:04 PM
The Lady Mod


 

Join Date: Feb 2007
Location: Arkansas
Posts: 8,512
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Send a message via Yahoo to Granny
My first thought is that you tunes may be mis-labeled or your chip could be messed up. That is just my thoughts.
Reply With Quote Quick reply to this message
  #4  
Old 04-26-2008, 07:04 PM
Compression Ignition Addict
 
Join Date: Oct 2007
Location: Irmo, SC
Posts: 2,134
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Send a message via AIM to SteveKran Send a message via Yahoo to SteveKran
That's pretty rough man....hopefully you'll get it right without too big of a headache
Reply With Quote Quick reply to this message
  #5  
Old 04-26-2008, 07:07 PM
COME ON...ONE TIME!!


 

Join Date: Sep 2007
Location: Fletcher, NC
Posts: 16,644
Thanks: 61
Thanked 53 Times in 52 Posts
Feedback Score: 0 reviews
Granny, I am gonna talk to tony about that. I thought that too. He showed my dynos of local 7.3s with a TS chip or DP tuner, and they were 400HP+ and 700 ft/lbs. I am way off from that!!!
Reply With Quote Quick reply to this message
  #6  
Old 04-26-2008, 07:13 PM
My 6OH Hates Me


 

Join Date: Sep 2007
Location: Nexus of the Universe
Posts: 24,738
Thanks: 8
Thanked 17 Times in 16 Posts
Feedback Score: 1 reviews
Ya bud I would have the chip checked it may be part of the problem
Reply With Quote Quick reply to this message
  #7  
Old 04-26-2008, 07:15 PM
COME ON...ONE TIME!!


 

Join Date: Sep 2007
Location: Fletcher, NC
Posts: 16,644
Thanks: 61
Thanked 53 Times in 52 Posts
Feedback Score: 0 reviews
Hopefully, its the chip. And, I can find the leak on the underside of the pedistal, causing low oil pressure. That would be an answer to my long time praying!! Matt Gouge(Spartan Diesel) tells me that sometimes that the oil pickup tube can sometimes crack, causeing aireation in the oil, and low pressure. I would have to pull motor for that. Even to see if that is the problem would have to pull the motor. I am hoping not!!
Reply With Quote Quick reply to this message
  #8  
Old 04-26-2008, 07:18 PM
The Lady Mod


 

Join Date: Feb 2007
Location: Arkansas
Posts: 8,512
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Send a message via Yahoo to Granny
That would not be good to have to pull the motor!
Reply With Quote Quick reply to this message
  #9  
Old 04-26-2008, 07:47 PM
COME ON...ONE TIME!!


 

Join Date: Sep 2007
Location: Fletcher, NC
Posts: 16,644
Thanks: 61
Thanked 53 Times in 52 Posts
Feedback Score: 0 reviews
Oil leak possibly?

ok, you wanna see a BAD oil leak? here is one! this is after 5 dyno pulls!!


Nice huh? Oh yeah! forgot about the trans fluid. seems to come from the front. any ideas? Jeeze!! I cant catch a break! My truck is sick!!
Reply With Quote Quick reply to this message
  #10  
Old 04-26-2008, 08:39 PM
Compression Ignition Addict
 

Join Date: Oct 2007
Location: Dunlap TN
Posts: 247
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
are dynos usually that hard on a truck??...geez...i thought about putting my truck on a dyno...but i dont wanna mess er up...
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 05:39 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors