speed related stall please help! - Ford Powerstroke Diesel Forum
User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 4 Old 07-26-2013, 02:09 PM Thread Starter
Powerstroke.org Rookie
 
Join Date: Jul 2013
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
speed related stall please help!

Got to drive this truck from KY to WI. When I get to 32 mph the truck dies as if the key was turned off and will not fire until the speed comes down. I have replaced uvch , IPR, ICP and fuel filter. No check engine line or anything. Any thoughts? Any help is Appreciated.

Edit: early 99 7.3 6 speed

Last edited by 1chancew; 07-26-2013 at 02:16 PM.
1chancew is offline  
Sponsored Links
Advertisement
 
post #2 of 4 Old 07-26-2013, 03:36 PM
Compression Ignition Addict
 
Join Date: Dec 2007
Posts: 5,967
Mentioned: 3 Post(s)
Tagged: 0 Thread(s)
Quoted: 37 Post(s)
Thanks: 5
Thanked 204 Times in 195 Posts
Feedback Score: 3 reviews
Fuel Delivery?

So, it's maybe rpm and not mph that's the issue. Change the Fuel Filter
NoRalPh is offline  
post #3 of 4 Old 07-26-2013, 06:26 PM
Powerstroke.org Rookie
 
Join Date: Jul 2013
Posts: 9
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
just because check engine light is not on does not mean there is no active codes i would put a scanner on it. could be crank sensor issue
posreairs2013 is offline  
post #4 of 4 Old 07-27-2013, 01:46 PM Thread Starter
Powerstroke.org Rookie
 
Join Date: Jul 2013
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
It isn't rpm related as it will shut down at idle if you are going down hill clutch in. As long as you hit 32. It's coming and going, sometime runs like a champ other times it will shut down. Took it to the ford dealer it had a speed sensor cod of some kind. I checked the wires over the diff and someone had spliced them in cheap fashion and taped them together. I replaced the sensor and plug. So for so good, but the behavior is erratic to soon to tell.
1chancew is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome