Keeps dying - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 04-18-2008, 10:49 PM
Compression Ignition Addict
 

Join Date: Dec 2007
Location: casper wy
Posts: 325
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Send a message via MSN to wyoming
Keeps dying

Ok my truck keeps dying after slow acceluration from a low Rpm. And it's getting worse fast!! there is a point in my low power band that the truck just dies. It idles fine, but if I give it gas even in park it will die. if you give it hard gas it will hesitate at that point but get past it and run, till you let off the gas then it will die. Once I get past that point it runs fine no hesitation or any thing in drive. to put it in perspective a 4 block drive you will have to restart the truck about 10 times, it dies every time you slow down then accelerate it will die. The problem seems to be around 5 mph. if you hard accelurate through that area the engine sounds really quiet no rattling. This is really dangerous problem, It gives you enough gas to get into an intersection then dies. I just had stage 1 injectors put in and it ran fine for the last week. This just started today. Could it be the HPOP? No codes I reprogramed it several times (thought it might be the programer) I did notice that in race it seemed to be worse. Any Ideas???????????????
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 04-18-2008, 11:07 PM
Compression Ignition Addict
 

Join Date: May 2007
Location: America
Posts: 6,782
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
How is your oil level.
Reply With Quote Quick reply to this message
  #3  
Old 04-20-2008, 04:13 AM
Member
 

Join Date: Feb 2008
Location: Abilene
Posts: 38
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
You may try swapping out your IDM. My truck was running real bad, thought it was injectors, changed them out and it got worse. Swapped the IDM out with a friends spare, and it ran great. I am waiting for my new one to arrive, but in the mean time I am running with my bad one and with the new Stage 1 injectors I put in it acts like it wants to die when I push in the clutch after deceleration. Acceleration is not a problem, just decel. Good luck.
Reply With Quote Quick reply to this message
  #4  
Old 04-20-2008, 09:06 AM
Compression Ignition Addict
 

Join Date: Dec 2007
Location: casper wy
Posts: 325
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Send a message via MSN to wyoming
Thanks for the help. It was the IPR vavle, it came apart. Got it put back together and it is running fine now.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 09:58 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors