and the puking starts again - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 04-17-2008, 09:20 PM
Compression Ignition Addict
 

Join Date: Sep 2007
Location: Toms River, NJ
Posts: 3,720
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Send a message via AIM to 03f250stroke
Angry and the puking starts again

Hate to say it but the truck is puking again. I got my studs down within the last month, ARP put in, new HPOP, new EGR cooler, new EGR valve, new gaskets, new VGT solenoid, new i/c boots, new thermostat.

I picked the truck up after having all this done, truck ran STRONG, went on vacation for about 2 weeks and got home last night, I wanted to take it for a ride so I went to start it. It just cranked for a while and I thought it was the batteries? Finally it like kicked over sorta but didnt fully start, BIG cloud of smoke. White/gray. Then I got it to run. Ran ok but smoked a little and it was dark out so I couldnt really see. Today got home from work around 4. I was actually talking to Nate on the phone when this was happening, the truck would just crank. took it about 2-3 mins to turn over. When it finally did WOW the cloud was huge, pure white. Hazed white for the time it was running. Took it for a ride, rough idle, smokey as hell, still had power though. I am thinking maybe the heads are bad? IDK anymore, I just had this stuff done last month, I probably put 200 miles on the truck since I got it back. Anybody have any idea whats going on.

Im dropping it off to the dealer again in the morning and let them look at it. So either way I let you guys know the outcome and see what happens tomorrow.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 04-17-2008, 09:22 PM
Compression Ignition Addict
 

Join Date: May 2007
Location: America
Posts: 6,783
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
Maybe EGR cooler cracked and coolant is getting into the intake.
Reply With Quote Quick reply to this message
  #3  
Old 04-17-2008, 09:28 PM
Compression Ignition Addict
 

Join Date: Sep 2007
Location: Toms River, NJ
Posts: 3,720
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Send a message via AIM to 03f250stroke
they did replace the cooler with a brand new one, Im wondering if that is the problem, if it is then Im going to get the egr delete kit from elite and be done with that, the sct turns it off I believe but doesnt stop gasses from going in there?!. this damn EGR cooler!
Reply With Quote Quick reply to this message
  #4  
Old 04-17-2008, 09:43 PM
Compression Ignition Addict
 

Join Date: Nov 2007
Location: Las Vegas, Nevada
Posts: 1,039
Thanks: 0
Thanked 2 Times in 2 Posts
Feedback Score: 0 reviews
That sucks Evan, sorry to hear the rotten luck. hopefully its not the heads.
Reply With Quote Quick reply to this message
  #5  
Old 04-17-2008, 09:47 PM
Compression Ignition Addict
 

Join Date: May 2007
Location: America
Posts: 6,783
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
I've heard of cases were it took 3 EGR coolers to fix the problem. I think Evel Eye went through 3 before he blocked his off.
Reply With Quote Quick reply to this message
  #6  
Old 04-17-2008, 10:27 PM
Compression Ignition Addict
 

Join Date: Aug 2007
Location: Denver, CO
Posts: 1,034
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
good luck buddy hope everything works out
Reply With Quote Quick reply to this message
  #7  
Old 04-18-2008, 06:16 AM
Compression Ignition Addict
 

Join Date: Sep 2007
Location: Toms River, NJ
Posts: 3,720
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Send a message via AIM to 03f250stroke
thanks alot guys, just got back from the dealer today..really weird, took the sct off, drove it to the dealer, we did a bunch of tests, everything passed, then we loaded the sct back up, PERFECT!. I drove home blowing black the whole time. I dont know what happened, maybe because it sat for a little while??? Either way, Elite is getting a call from me today!

thank you to everyone for the help, Ill see what happens with the truck today.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 05:59 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors