Driving and all of a sudden no power then it shut off. - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 06-24-2013, 10:39 PM
Member
 

Join Date: Apr 2013
Posts: 32
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Driving and all of a sudden no power then it shut off.

doing maybe 55-60 i notice no power then it just dropped to 0 rpms.

when cranking the ICP is no higher than 390. that mean its a HPOP? usually when idling its anywhere from 550-900.

Dip stick wasn't showing much oil in it so i threw 10qts into it and it still wasn't hardly showing so it may just leaked everything out even tho i could not see any oil spots, was at night tho as well.

anything else i can check, truck will not even try to start.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 06-25-2013, 05:08 AM
Compression Ignition Addict
 

Join Date: Apr 2012
Location: Asheville, NC
Posts: 312
Thanks: 0
Thanked 5 Times in 5 Posts
Feedback Score: 0 reviews
Without oil pressure your HPOP won't work. It's hard to believe that you put 10 quarts of oil in it and it disappeared. Now that it's daylight you might want to take another look.
Reply With Quote Quick reply to this message
  #3  
Old 06-25-2013, 06:56 AM
Member
 

Join Date: Apr 2013
Posts: 32
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by AshevilleEngine.com View Post
Without oil pressure your HPOP won't work. It's hard to believe that you put 10 quarts of oil in it and it disappeared. Now that it's daylight you might want to take another look.
yeah I'm about to go head over to where it is. I had the ICP sensor o ring break on me and it leaked more than 5qts just idling for like 2 mins. It looks wet again so i may have been that but the bottom of the motor didn't look real oily.
Reply With Quote Quick reply to this message
  #4  
Old 06-25-2013, 09:44 AM
Member
 

Join Date: Apr 2013
Posts: 32
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
well truck started, i added oil now its way over the max line so i have to drain some..

when i hit the throttle the rpms actually drop or don't move at all and it'll puff out blue smoke?

is this because to much oil, not throwing any codes other than for the egr delete
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 07:20 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors