headlights and windows not working - Ford Powerstroke Diesel Forum
User Tag List

LinkBack Thread Tools Display Modes
post #1 of 1 Old 06-19-2013, 08:13 PM Thread Starter
Powerstroke.org Rookie
Join Date: Jun 2013
Location: Baltimore
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
headlights and windows not working

Sorry if this is a newbie question. I have a 2001 7.3 Excursion that I put a TS 6 position chip in. After the install I checked the windows and headlights and neither worked. I then noticed that the ABS light was on. I removed the chip and called to confirm that it was the correct one. It was, and magically the windows started working! And then they stopped. The radios constant power seemed to be not working...and then it started to work also.

I checked every single fuse and all of them are good.

I read Radio and windows stopped working...

So I don't know if it is a relay or not or should I just start replacing relays. I haven't tried banging on the dash or slamming the door.

Any help would be greatly appreciated.
jglantz78 is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome