lots of white smoke out the exhaust - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 06-11-2013, 06:06 AM
Premium Member

 

Join Date: Jun 2013
Location: Camden County
Posts: 945
Thanks: 2
Thanked 7 Times in 7 Posts
Feedback Score: 3 reviews
lots of white smoke out the exhaust

Blowing a lot of white smoke during acceleration. No boost, egr codes popped on after restart but not during. Did i lose and egr cooler, turbo seals? truck ran normal a short while after. 2007 6.0l f250 with edge evolution cts. Please help!
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 06-11-2013, 07:26 AM
Premium Member

 

Join Date: Jun 2013
Location: Camden County
Posts: 945
Thanks: 2
Thanked 7 Times in 7 Posts
Feedback Score: 3 reviews
20 psi is boost at wot
Reply With Quote Quick reply to this message
  #3  
Old 06-11-2013, 08:58 AM
Premium Member

 

Join Date: Jun 2013
Location: Camden County
Posts: 945
Thanks: 2
Thanked 7 Times in 7 Posts
Feedback Score: 3 reviews
Oil does not appear to be contaminated, looks and smells fine. Coolant looks good and is not low, no obvious leaks near turbo or oil cooler.
Reply With Quote Quick reply to this message
  #4  
Old 06-11-2013, 09:19 AM
Premium Member

 

Join Date: Jun 2013
Location: Camden County
Posts: 945
Thanks: 2
Thanked 7 Times in 7 Posts
Feedback Score: 3 reviews
P0404 and P0683 are showing at start up. Idle is smooth and revs normal.
Reply With Quote Quick reply to this message
  #5  
Old 06-12-2013, 08:00 AM
Premium Member

 

Join Date: Jun 2013
Location: Camden County
Posts: 945
Thanks: 2
Thanked 7 Times in 7 Posts
Feedback Score: 3 reviews
unplugged the EGR valve, truck runs better than when i first bought it.
Reply With Quote Quick reply to this message
  #6  
Old 06-14-2013, 10:48 PM
Compression Ignition Addict
 

Join Date: Apr 2013
Posts: 182
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by powerstrokeshellback View Post
Blowing a lot of white smoke during acceleration. No boost, egr codes popped on after restart but not during. Did i lose and egr cooler, turbo seals? truck ran normal a short while after. 2007 6.0l f250 with edge evolution cts. Please help!

has to be either egr cooler bad or injector o-ring or cracked injector tip.does the white smoke smell sweet or burns your eyes .if it's sweet it's your egr cooler if it burns your eyes chances are you have an o-ring on an injector bad.
Reply With Quote Quick reply to this message
  #7  
Old 06-15-2013, 01:24 PM
Premium Member

 

Join Date: Jun 2013
Location: Camden County
Posts: 945
Thanks: 2
Thanked 7 Times in 7 Posts
Feedback Score: 3 reviews
The white smoke was only for a short period of time, and hasn't done it since. I did find some oil in the intake tube that runs from the cac to the intake elbow, is that normal
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 05:45 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors