Bad Fuel, Or Something - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 03-12-2008, 11:53 PM
Powerstroke.org Rookie
 

Join Date: Nov 2005
Location: Northern Kentucky
Posts: 26
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Bad Fuel, Or Something

I put $100 of Diesel fuel in my truck last friday, went 5 miles and lost all horsepower.

Was able to take it to a nearby garage, barely had enough power to pull it into the bay.


Fast forward to monday, they changed out dirty filters but still could not get the truck running right, end of the day it wouldn't even start.


The garage had the equipment to test fuel pressure on the 7.3's but not my 6.o so it was towed to ford to get a diagnostic, find out if the fuel pump is bad in the tank.



I'm renting a SUV to get by right now and this is BS that I'm day 6 without wheels.

IS it true that these fords have problems with the fuel pump on diesels? That's the rumor and didn't know if it was true or not.


I need to build a fire under someone to get this truck mobile and was hoping someone can give me insight as to whether this is a common problem or the "other" possibility that's being overlooked.

I'm 4 months from trading this truck in and this money I'm putting out, I hope I can go chase the gas station legally for contamination of fuel.


Anyone ever successfully beat a gas station for that?

I was told by the second manager that they "just fueled the tanks" right before I arrived.

IF I would of seen them fueling the tanks, I skip the station all together knowing what I'm dealing with right now.


Any help is appreciated, thanks in advance.


S

Last edited by DUNBAR; 03-28-2008 at 09:46 AM.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 03-28-2008, 09:51 AM
Powerstroke.org Rookie
 

Join Date: Nov 2005
Location: Northern Kentucky
Posts: 26
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Totally off the marks

It was not fuel.....but the filters did need to be changed.


EGR valve was carboned up, badly from all the city driving.


Yesterday.......truck started to lose power again.


What I noticed a few days after this incident was the smell of radiator fluid.....and that I was lacking some in my reservoir.


Now, I take it back to the ford and they are telling me that the EGR cooler is leaking radiator fluid into the motor and he described the symptoms to a tee to what I experienced lately.


Hard to understand why this was happening in sequence.....which is BS in my opinion but there's no way for me to tell.


The bottom line is that this whole thing is getting expensive renting vehicles every time this happens.


I'm going to ask if there's anything else that could cause more problems while they are in there to see what "can" happen.


I'm going to search this site to see if anyone else has had this luxury repair.

It is however covered by warranty.


Page 37: Air Management System

Last edited by DUNBAR; 03-28-2008 at 09:54 AM.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 01:56 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors