95 F350 PSD loses power then died on hwy - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 03-01-2008, 10:22 PM
Powerstroke.org Rookie
 

Join Date: Mar 2008
Location: Loveland, CO
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Unhappy 95 F350 PSD loses power then died on hwy

I have a 95 F350 powerstroke diesel that started losing power the past month. This happens around 55-65 mph and there just won't be any power (but the truck doesn't die). It will slow to around 35-40 mph and I'll have to pull over. While waiting it will idle rough and then after a few minutes when I rev the engine it will idle normally. When I drive again, everything is fine. This has happened every few days or so. Had an oil change last weekend and it seemed to run better after new air filter, etc (fuel filter not changed). Yesterday my husband took the truck to Wyoming for a job and it lost power and then died on the interstate. He waited about 30 minutes and was finally able to get it restarted. He made it to Casper by driving under 65 mph (still lost power and died 3 more times). Today on his way home, it lost power again on the interstate, died, and this time would not start for anything. My uncle is on the way to Wyoming with his flatbed to bring it home to Colorado. Husband replaced the CPS 3 years ago (cost $175 from auto part store) and we had a new HPOP put in about 4 years ago. No engine light comes on. Tach moves when cranking engine, but no start now. Haven't noticed smoke color. Any ideas? I appreciate any help you could pass along.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 03-01-2008, 10:29 PM
Compression Ignition Addict
 

Join Date: Jan 2008
Location: God's Country
Posts: 421
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Sounds like a fuel problem!!! Might need to check the fuel press to see what it is running. Factory specs should be somewhere around 60 to 65 lbs. If it's not getting fuel, then she will CROAK!!!!
Reply With Quote Quick reply to this message
  #3  
Old 03-01-2008, 10:29 PM
Compression Ignition Addict
 

Join Date: Feb 2008
Location: denver
Posts: 203
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Send a message via AIM to 06Blackmamba Send a message via Yahoo to 06Blackmamba
hi from brighton colorado. that odd just a thought but maybe the injector harness is shorting out and causeing it to lose pressure my 01 did that and it ended up being the injector harness rubbing on the cover.
Reply With Quote Quick reply to this message
  #4  
Old 03-01-2008, 10:30 PM
allergic to hot weather

 

Join Date: Nov 2007
Location: Anchor Point, AK
Posts: 1,208
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Send a message via AIM to 95and05 Send a message via MSN to 95and05
3 years ago they had still not updated the CPS and the new improved modles are cheaper... $28 in Alaska so cheap in comparison. any codes been pulled?
Reply With Quote Quick reply to this message
  #5  
Old 03-01-2008, 10:39 PM
allergic to hot weather

 

Join Date: Nov 2007
Location: Anchor Point, AK
Posts: 1,208
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Send a message via AIM to 95and05 Send a message via MSN to 95and05
oh and

you will get addicted to this site so be careful.
Reply With Quote Quick reply to this message
  #6  
Old 03-01-2008, 10:45 PM
Powerstroke.org Rookie
 

Join Date: Mar 2008
Location: Loveland, CO
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Thanks for the quick replies - haven't had a chance to see if it has any codes pulled - 12:46 am here and it's on the flatbed on it's way home from WY. I'll have him check tomorrow and will pass along your suggestions. You guys are the best! Thanks!!
Reply With Quote Quick reply to this message
  #7  
Old 03-01-2008, 10:54 PM
Compression Ignition Addict
 

Join Date: Jan 2008
Location: God's Country
Posts: 421
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
You're welcome. Good luck. Pass along anything you guys find out on codes or otherwise.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 08:12 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors