7.3 Power loss, Loud Noise and coolant loss - Ford Powerstroke Diesel Forum

 
LinkBack Thread Tools Display Modes
post #1 of 5 Old 02-17-2008, 04:30 PM Thread Starter
Member
 
Join Date: Aug 2006
Posts: 53
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
7.3 Power loss, Loud Noise and coolant loss

OK, I was driving down the road around 70. Accelerated to pass a car and suddenly under boost, it souded like a train horn went off under the hood. I only hear the noise when boost hit 5lbs or greater. Seems to be loosing coolant from the from of the motor some where. The noise sounds identical to a train horn and seems to come from the front of the motor. Checked for leaks and couldnt find it. Thinking maybe the intake or something similar. Any Ideas?????
Bellflower is offline  
post #2 of 5 Old 02-18-2008, 03:40 PM
Compression Ignition Addict
 
~CrazyDiesel~'s Avatar
 
Join Date: Nov 2006
Location: Butner, NC
Posts: 255
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Send a message via AIM to ~CrazyDiesel~ Send a message via MSN to ~CrazyDiesel~ Send a message via Yahoo to ~CrazyDiesel~
If it's coming from the front, and you're losing coolant, then I'd think your water pump has gone south. About $150-160 for a new one, easy to put on.

But, don't take what I am saying for truth, I might be wrong

I'm sure someone else whop knows lots more than I will be along shortly.

June of 1999 7.3L F-250 CCSB
Dp-Tuner F5 w/8 Tunes. Autometer Colbalt Gauges. 5" Exhaust. 2004 6.0 SCT and Headstuds 4" exhaust
2008 6.4L project truck.
[/COLOR]



~CrazyDiesel~ is offline  
post #3 of 5 Old 02-18-2008, 03:41 PM
Compression Ignition Addict
 
~CrazyDiesel~'s Avatar
 
Join Date: Nov 2006
Location: Butner, NC
Posts: 255
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Send a message via AIM to ~CrazyDiesel~ Send a message via MSN to ~CrazyDiesel~ Send a message via Yahoo to ~CrazyDiesel~
but it does it under boost?

Turbo hitting the housing maybe? PUll the intake and grab the compressor wheel and move it, should have very little play (barely perceptible)

June of 1999 7.3L F-250 CCSB
Dp-Tuner F5 w/8 Tunes. Autometer Colbalt Gauges. 5" Exhaust. 2004 6.0 SCT and Headstuds 4" exhaust
2008 6.4L project truck.
[/COLOR]



~CrazyDiesel~ is offline  
post #4 of 5 Old 02-18-2008, 03:42 PM
Banned
 
Join Date: Jan 2006
Location: central coast, california
Posts: 0
Thanks: 0
Thanked 5 Times in 3 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Quote:
Originally Posted by ~CrazyDiesel~ View Post
but it does it under boost?

Turbo hitting the housing maybe? PUll the intake and grab the compressor wheel and move it, should have very little play (barely perceptible)
that would be my guess
mschn99 is offline  
post #5 of 5 Old 02-19-2008, 03:52 AM Thread Starter
Member
 
Join Date: Aug 2006
Posts: 53
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Fixed

OK, Had 2 problems at once, water pump going south and Coupler came off the turbo. fixed and runs great now. Thanks guys
Bellflower is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome