7.3 powerstroke wont charge - Ford Powerstroke Diesel Forum
User Tag List

LinkBack Thread Tools Display Modes
post #1 of 1 Old 04-22-2013, 09:08 AM Thread Starter
Powerstroke.org Rookie
Join Date: Apr 2013
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
7.3 powerstroke wont charge

Hey gents,
here is what I got.
both batts are a month old and retested to ensure they are good. tested alternator at 2 different stores and ohmed it out myself. it is good. I bought a new Alternator anyway to be safe. No battery light is on while truck in running Replaced fuses underhood and in cab. replaced 470 ohm resist on the gauge cluster. With truck running I get 11.5 volts at the #6 fuse under hood, at the battery, the post on on the alternator and at the starter relay where the fusible links connect to the battery. I get 11.5 volts at the #29 fuse at the inside fuseblock. also where the plug goes into the back of the gauge cluster, and at the signal wire on the back of the ALT. hope someone can help and thanks

2000 f250 7.3

Last edited by JLBunn03; 04-22-2013 at 09:09 AM. Reason: More information
JLBunn03 is offline  
Sponsored Links

alternator, battery, charging, charging system, fuse

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome