6.4L No Turbo and sounds weird after changing oil cooler - Ford Powerstroke Diesel Forum
User Tag List

LinkBack Thread Tools Display Modes
post #1 of 2 Old 03-29-2013, 03:59 AM Thread Starter
Powerstroke.org Rookie
Join Date: Mar 2013
Location: Pensacola, Fl
Posts: 8
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
6.4L No Turbo and sounds weird after changing oil cooler

Got the truck back together after changing the oil cooler and I don't have any turbo pressure on the gage, turbo sounds like it has a slight rubbing or something, and seems to be ideling high. Any ideas?
Homebuldr1 is offline  
Sponsored Links
post #2 of 2 Old 03-29-2013, 04:08 AM
Compression Ignition Addict
05_PSD_Erik's Avatar
Join Date: Feb 2009
Location: Mercer County WV
Posts: 2,988
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 2
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
I have never removed the 6.4 turbos before. But with any turbo, I would make sure you have all the connections tight as a loose up pipe can cause major lack of boost. The rubbing sound could be a turbo problem, or it could be the loose up pipe vibrating against the turbo feed inlet. Just the metal of the pipe and the flange rubbing together from the vibration of the truck. Good luck finding your issue!

2009 Subaru WRX Premium
Muffler Delete

Had to park it with some real diesel muscle....
05_PSD_Erik is offline  
Sponsored Links

6.4l, turbo issue problem

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome