Wiring Gremlins 03 F350 6 L - Ford Powerstroke Diesel Forum
User Tag List

LinkBack Thread Tools Display Modes
post #1 of 1 Old 03-14-2013, 02:39 PM Thread Starter
Powerstroke.org Rookie
Join Date: Oct 2012
Location: Canada
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Unhappy Wiring Gremlins 03 F350 6 L

Hi all:
Will apologize in advance on the length of this.

I have a real problem with my 03 F350 6 L, Company I work for bought the truck used came with all repair bills and was in good shape and ran fine.
Late last summer the fuel injector pump went, had it towed to a shop they replaced the fuel pump, also a ERG delete kit installed.

Picked up the truck felt like it was shuddering a bit truck had been down for about three months by now and it had a full tank of fuel from the summer in it, thought that as it was cold it might just need some anti gel conditioner and possible new fuel filters. Added some winter fuel and mixed with conditioner truck seemed to settle right down ran good.

Two days later truck losses power took my foot off the throttle pressed down again picked right back up seemed to run good again?
Took it home lost power again then stalled got it going again would power out then run ok . Next thing the WTS light comes on loss power again take foot off pedal then works fine.
Goes back to the shop they replace the the glow plug module Crank/Cam sensor and the wiring harness connector had them check all the connections and plug in and had them cleaned. Truck ran ok for a month now the WTS light comes on again, had Ford check it out no codes the first time they took it for a run checked the codes again got a code for the Turbo saying the vanes are dirty this is a new TSB from ford ??? First shop had to take the turbo off to get to the fuel pump said every thing was good.
Really need some insight on this as my lively hood depends on this truck.

Hoping some one has some answer if its a big fix again will be out of a job.
Here are the codes that came up the first time it went back, I have run the old 7.3 for many years and I am not that familiar with the 6 L and what the quirks are in these.
P 132B Turbo Boost
P 0603
P 0672
P 0678
ICP Sensor Cam P2614 Cam Position Circuit P2617

Last edited by Warden54; 03-15-2013 at 07:26 AM. Reason: Addintional Info
Warden54 is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome