6.0 hot start problem - Ford Powerstroke Diesel Forum
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 12 Old 03-06-2013, 05:45 PM Thread Starter
Member
 
Join Date: Aug 2011
Posts: 50
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
6.0 hot start problem

So this is my daily driver and I am afraid its going to break down. It has code p2291 and I am frustrated with it. The truck has an adrenaline hpop a brand new ipr valve the new style dummy plugs and up tubes. The only thing it could be is the icp sensor right. It has hot start issues and that is all.
seabees is offline  
post #2 of 12 Old 03-06-2013, 05:47 PM
Powerstroke Tech

 
whitestrikr21's Avatar
 
Join Date: May 2010
Posts: 179
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 3 Post(s)
Garage
Feedback Score: 0 reviews
6.0 hot start problem

Did you change the t-fitting with the pump? Best bet is to air check the high pressure oil system. Remove the icp and connect a air line listen for leaks and just follow the hissing. If nothing is herd try an icp sensor


Sent from AutoGuide.com Free App



03 F-350 Crew Cab short bed
6.0l
Arp studs
XDP Coolant filter
Sct Sf3- idp tunes
Silverline staintless turbo back 4"
XDP egr delete

whitestrikr21 is offline  
post #3 of 12 Old 03-06-2013, 05:49 PM
Powerstroke Tech

 
whitestrikr21's Avatar
 
Join Date: May 2010
Posts: 179
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 3 Post(s)
Garage
Feedback Score: 0 reviews
6.0 hot start problem

Also check the small Allen head silver plugs in the high pressure oils rails make sure the o ring is good and the plug is tight


Sent from AutoGuide.com Free App



03 F-350 Crew Cab short bed
6.0l
Arp studs
XDP Coolant filter
Sct Sf3- idp tunes
Silverline staintless turbo back 4"
XDP egr delete

whitestrikr21 is offline  
post #4 of 12 Old 03-06-2013, 05:54 PM Thread Starter
Member
 
Join Date: Aug 2011
Posts: 50
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
It is an early 04 so no sct fitting for me.
seabees is offline  
post #5 of 12 Old 03-06-2013, 05:59 PM
Powerstroke Tech

 
whitestrikr21's Avatar
 
Join Date: May 2010
Posts: 179
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 3 Post(s)
Garage
Feedback Score: 0 reviews
6.0 hot start problem

Ok was unaware its the old style pump how are all the pump and pump feed tube o rings? There is definetly a high pressure oil leak to set the 2291 which I believe to be a icp too low code. How does it run any surging, does it stall out or just won't start after being shut down hot?


Sent from AutoGuide.com Free App



03 F-350 Crew Cab short bed
6.0l
Arp studs
XDP Coolant filter
Sct Sf3- idp tunes
Silverline staintless turbo back 4"
XDP egr delete

whitestrikr21 is offline  
post #6 of 12 Old 03-06-2013, 06:07 PM Thread Starter
Member
 
Join Date: Aug 2011
Posts: 50
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Truck runs great. Just once its hot it wont start until she cools down a bit. I tapped on the sensor once and it fired off. I had the motor out less than a year ago and it got a full overhaul. All updated parts in her except I put a few cheap ebay sensors in one being the icp just replace tje ipr with a new ford factory part
seabees is offline  
post #7 of 12 Old 03-06-2013, 06:14 PM
Powerstroke Tech

 
whitestrikr21's Avatar
 
Join Date: May 2010
Posts: 179
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 3 Post(s)
Garage
Feedback Score: 0 reviews
6.0 hot start problem

Try unplugging the icp sensor and see what happens. That should be it in a sort of limp mode and raise the icp to max pressure. Also when you unplug it check to see if the connector has oil on it if so replace the sensor and connector with an oem ford one


Sent from AutoGuide.com Free App



03 F-350 Crew Cab short bed
6.0l
Arp studs
XDP Coolant filter
Sct Sf3- idp tunes
Silverline staintless turbo back 4"
XDP egr delete

whitestrikr21 is offline  
post #8 of 12 Old 03-06-2013, 06:17 PM Thread Starter
Member
 
Join Date: Aug 2011
Posts: 50
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Ok i will give it all a whirl thank you for the advice
seabees is offline  
post #9 of 12 Old 03-06-2013, 06:19 PM
Powerstroke Tech

 
whitestrikr21's Avatar
 
Join Date: May 2010
Posts: 179
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 3 Post(s)
Garage
Feedback Score: 0 reviews
6.0 hot start problem

No problem let me know how it goes


Sent from AutoGuide.com Free App



03 F-350 Crew Cab short bed
6.0l
Arp studs
XDP Coolant filter
Sct Sf3- idp tunes
Silverline staintless turbo back 4"
XDP egr delete

whitestrikr21 is offline  
post #10 of 12 Old 03-06-2013, 08:08 PM
Powerstroke Techie
 
Join Date: Apr 2012
Posts: 2,398
Thanks: 46
Thanked 98 Times in 98 Posts
Mentioned: 53 Post(s)
Quoted: 129 Post(s)
Feedback Score: 0 reviews
could be an injector o ring.
i doubt it's the sensor. 2291 is a performance code. a bad sensor would more likely throw a circuit code

the richest ones are not those who have the most, but those who need the least
kaya is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome