'05 6.0 no start after repairs - Ford Powerstroke Diesel Forum

 
LinkBack Thread Tools Display Modes
post #1 of 2 Old 02-23-2013, 04:08 PM Thread Starter
Powerstroke.org Rookie
 
Join Date: Feb 2013
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
'05 6.0 no start after repairs

Hey guys, I'm desperate. Last weekend, I tore into my 6.0. The egr cooler had gone bad. I did the egr delete, replaced engine oil cooler. I was going to replace stc fitting on hpop, but discovered it had already been upgraded. So I just replaced all the o-rings and pressure sensor screen, and reinstalled. I got everything done and put back together. Went to start, it started and died, I tried again, took a bit, but started and died. I have not been able to start it since. I've run batteries down twice now. It will not start. If anyone knows anything, please help. I checked all connections including FICM. I'm all out of ideas, and have to get my truck back on the road! Please help!
mikewr1978 is offline  
post #2 of 2 Old 03-08-2013, 06:52 PM
Powerstroke.org Fanatic
 
RACERX's Avatar
 
Join Date: Feb 2011
Posts: 106
Thanks: 1
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Cam shaft sensor?
RACERX is offline  
Reply

Tags
6.0 , egr , hpop , no start , oil cooler

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome