97 7.3 idle problems - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 12-19-2007, 11:59 AM
Powerstroke.org Rookie
 

Join Date: Dec 2007
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
97 7.3 idle problems

Have a 97 F-250 4x4 all stock, when you first crank it up it idles really rough, I mean rough to the point to where it won't idle unless you hold pressure on the pedal. BUT, If you get in, turn the key on, hold the pedal down just enought to hear that little switch on the pedal assmb. click, then crank it, it idles perfect. When it does crank, lots of white smoke which Im figuring is normal for cold mornings, runs good just every once in a blue moon it will miss at low rpms while accelerating.

2nd problem, Crank it up, get it to idle, let it warm up, sometimes when you put it in reverse, it will go and act like a manual transmission like the torque converters not even there, just a direct drive, hit the brake, it chokes down then you can fire it up and shes good to go.

Any help would be greatly appreciated!
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 12-19-2007, 12:17 PM
Infidel

 

Join Date: Jun 2006
Location: Texas
Posts: 5,166
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Hmmmmmm no idea, so here's a bump for others to look at it.
Craig
Reply With Quote Quick reply to this message
  #3  
Old 12-19-2007, 12:41 PM
Navy Beer Guzzler

 

Join Date: Jan 2007
Location: Leander, Texas
Posts: 264
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
On the Idle problem do you use any oil additives Mine started doing that after adding lucas oil stabilizer. I am still trying to get all that junk out but that LOS makes the oil foam and other problems. Remove the HPOP oil and replace it also.
Reply With Quote Quick reply to this message
  #4  
Old 12-19-2007, 03:02 PM
Powerstroke.org Rookie
 

Join Date: Dec 2007
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Nope, no oil additives also all maint. up to date
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 02:31 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors