bad shape please help - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 08-11-2006, 09:26 AM
Powerstroke.org Rookie
 

Join Date: Jan 2006
Posts: 26
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
bad shape please help

i have a 95 7.3 had a bad oil leak so i had a mech fix after doing so the resivoir for the high press system would not stay full . was told oil pump was going out since then i have a new oil pump,front cover,check valve,and high press regulator still doesnt work the truck will run if i manully fill resivoir it has a miss and im now being told that o rings on the injectors are blown ? will this cause the problem i am having or is there other problem im lost and have spent over 2g in parts and still dont have runnig truck please help:also my oil pressure gauge is not reading and was told that it wont because pressure cant build up with bad o rings

Last edited by chigger; 08-11-2006 at 11:30 AM.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 08-11-2006, 11:34 AM
Powerstroke.org Rookie
 

Join Date: Jan 2006
Posts: 26
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
also it ran fine before repairing oil cooler leak
Reply With Quote Quick reply to this message
  #3  
Old 08-11-2006, 02:37 PM
7.3 tech, supporter

 

Join Date: Jul 2006
Location: Wichita KS
Posts: 1,224
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
hang in there man, Marc should check in anytime and bieng the good guy he is he will check the 911 threads first.
Reply With Quote Quick reply to this message
  #4  
Old 08-11-2006, 04:30 PM
Banned
 

Join Date: Jan 2006
Location: central coast, california
Posts: 0
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by chigger
i have a 95 7.3 had a bad oil leak so i had a mech fix after doing so the resivoir for the high press system would not stay full . was told oil pump was going out since then i have a new oil pump,front cover,check valve,and high press regulator still doesnt work the truck will run if i manully fill resivoir it has a miss and im now being told that o rings on the injectors are blown ? will this cause the problem i am having or is there other problem im lost and have spent over 2g in parts and still dont have runnig truck please help:also my oil pressure gauge is not reading and was told that it wont because pressure cant build up with bad o rings
If the o rings for the injectors were that bad, that still doesnt explain why the low pressure pump wont fillt he resevour on its own after cranking.....Yes a very bad injector o ring situation could cause a bleed down, but it would leak into the fuel system. If the gauge wont register even when running, that tells me that either your sending unit is bad or that there is in fact low oil pressure, which would make sence..... Have they run a manual oil pressure check on the truck with it running??? The only other common reason for oil pressure to have problems, which would explain all your symptoms, would be worn main bearings......

How many miles on your rig agian???
Reply With Quote Quick reply to this message
  #5  
Old 08-16-2006, 07:20 AM
Powerstroke.org Rookie
 

Join Date: Jan 2006
Posts: 26
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
300,000 miles the mech theat worked on the truck said it had good oil press on the lower end also the truck sounds great running no banging or knocking but does have a miss
Reply With Quote Quick reply to this message
  #6  
Old 08-16-2006, 05:25 PM
Banned
 

Join Date: Jan 2006
Location: central coast, california
Posts: 0
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
there isnt any oil in your coolant is there???
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 08:29 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors