injector question HELP! - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 12-03-2007, 01:42 PM
Powerstroke.org Fanatic
 

Join Date: Aug 2007
Location: Idaho Falls Idaho
Posts: 142
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
injector question HELP!

My truck is driving me crazy! It won't start cold. It wants to but just chugs for a few seconds and dies. I plug it in and is starts but runs rough. It continually throws 1316 code. My mechanic has replaced the pcm, idm, fuel pump, cps, icp sensor, oil sending sensor, glow plug relay, and four glow plugs on drivers side and one injector on the front drivers side and a sensor on the transmission. Also two brand new interstate batteries and both under valve harnesses are new. He said everything checked out. The dealership also took my money to tell me everyting checked out ok. It still wouldn't run right.
So my mechanic decided to start over. He currently has both valve covers off. He discovered that the #8 injector is stamped LL on the top of it. He said this is not a ford stock injector. We're not sure if it is stock or high performance. What would happen if a high performance injector was put in with 7 stock ones? Should I have him replace it while he has the cover off? Has anyone come across an injector with LL stamped on it? He wants to put it back together and do a chemical injector cleaning and see if that helps. Should I replace the #8 injector?
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 12-03-2007, 02:09 PM
Desert Shield/Storm Vet

 

Join Date: Dec 2006
Location: Munising, MI.
Posts: 9,092
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
Wow looks like you took a good butt reaming!!! Wish I could help maybe the techs will see this and get you moving in the right direction
Reply With Quote Quick reply to this message
  #3  
Old 12-03-2007, 04:00 PM
Powerstroke.org Fanatic
 

Join Date: Aug 2007
Location: Idaho Falls Idaho
Posts: 142
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Bump
Anybody? Techs?
Thanks in advance
Reply With Quote Quick reply to this message
  #4  
Old 12-03-2007, 05:49 PM
Powerstroke Techie


 

Join Date: Jun 2007
Location: Huntsville/Arab alabama
Posts: 3,575
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Yea get a new mechanic, that guy has no idea what he is doing, LL is long lead, it is a ford factory injector installed only in number 8. He should refund you all your money and apologize for keeping your truck down that long and trying to work on it when he has no clue what he is doing.

It is fairly easy to test parts before replacing, never use a mechanic that like to just throw parts at it, any idiot can do that, heck I do from time to time.

Last edited by alabamafrog; 12-03-2007 at 05:53 PM.
Reply With Quote Quick reply to this message
  #5  
Old 12-03-2007, 05:53 PM
Jon
Guest
 
Posts: n/a
2nd that

Quote:
Originally Posted by alabamafrog View Post
Yea get a new mechanic, that guy has no idea what he is doing, LL is long lead, it is a ford factory injector installed only in number 8. He should refund you all your money and apologize for keeping your truck down that long and trying to work on it when he has no clue what he is doing.
Get a new mechanic. That right there tells me he has absolutly no right to even drive a diesel. Oh and I believe the '00 was the year that they had a different injector in the 8 hole for noise reasons. No performance difference.
Reply With Quote Quick reply to this message
  #6  
Old 12-03-2007, 05:57 PM
Powerstroke Techie


 

Join Date: Jun 2007
Location: Huntsville/Arab alabama
Posts: 3,575
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Anyone run a compression test and cylinder contribution test yet? Does it have bad blowby?
Reply With Quote Quick reply to this message
  #7  
Old 12-03-2007, 06:01 PM
International Threat
 

Join Date: May 2006
Location: Elkton, MD
Posts: 13,087
Thanks: 0
Thanked 6 Times in 4 Posts
Feedback Score: 1 reviews
Quote:
Originally Posted by gonestrokn View Post
My truck is driving me crazy! It won't start cold. It wants to but just chugs for a few seconds and dies. I plug it in and is starts but runs rough. It continually throws 1316 code. My mechanic has replaced the pcm, idm, fuel pump, cps, icp sensor, oil sending sensor, glow plug relay, and four glow plugs on drivers side and one injector on the front drivers side and a sensor on the transmission. Also two brand new interstate batteries and both under valve harnesses are new. He said everything checked out. The dealership also took my money to tell me everyting checked out ok. It still wouldn't run right.
So my mechanic decided to start over. He currently has both valve covers off. He discovered that the #8 injector is stamped LL on the top of it. He said this is not a ford stock injector. We're not sure if it is stock or high performance. What would happen if a high performance injector was put in with 7 stock ones? Should I have him replace it while he has the cover off? Has anyone come across an injector with LL stamped on it? He wants to put it back together and do a chemical injector cleaning and see if that helps. Should I replace the #8 injector?
are you sure he has done all of that?

I'm sorry... but sounds like he has no idea what he's doing. Are you sure that's the only code it ever had?

Like Alabamafrog mentioned... the LL is for long lead. It was put in to reduce the "cackle" that was associated with the dead head style fuel system.

Also bump for a tech to see this...
Reply With Quote Quick reply to this message
  #8  
Old 12-03-2007, 06:01 PM
Jon
Guest
 
Posts: n/a
oh hell

I was just gonna say that. Are you sure thats the only code it ever had. What did the dealer actually say?
Reply With Quote Quick reply to this message
  #9  
Old 12-04-2007, 04:02 AM
Powerstroke.org Fanatic
 

Join Date: Aug 2007
Location: Idaho Falls Idaho
Posts: 142
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Thanks for all the replys everyone. Thats good to know about the injector. My mech is putting the truck back together and chem cleaning the injectors, I guess that couldn't hurt after all the parts that have already been thrown at it !!?? If he doesn't get the problem figured out this time I guess I won't be back to that shop, the thing is, the dealership told me the truck was fixed, I don't think they knew much more, sure had know problems taking my 350 bucks to tell me that though and changed nothing on the truck. A compression test has been run and I'm told its ok there is no blow by and definatly no loss of power at least when it is running. There were a couple other codes but I can't remember, the 1316 is the last code that kept popping up. When I get the truck back I'll drive it awhile and see if more codes still pop up and let you guys know. Thanks again for the replys you guys are great.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 08:31 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors