Won't start blowing fuse - Ford Powerstroke Diesel Forum
 
LinkBack Thread Tools Display Modes
post #1 of 5 Old 11-24-2007, 05:07 PM Thread Starter
Powerstroke.org Rookie
 
Join Date: Feb 2007
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Won't start blowing fuse

99 - 7.3 turn key on blows #30 fuse, buddy broke down in WV. Thanks
cutty is offline  
Sponsored Links
Advertisement
 
post #2 of 5 Old 11-24-2007, 05:17 PM
Electrical Ogre
 
alberta 7.3's Avatar
 
Join Date: Aug 2007
Location: Calgary, Alberta
Posts: 12,151
Thanks: 30
Thanked 79 Times in 76 Posts
Mentioned: 1 Post(s)
Quoted: 108 Post(s)
Feedback Score: 1 reviews
Un plug the fuel heater (at bottom of filter bowl) the heater is probably shorted and blowing the fuse

Bill

1996 F250 SC/SB 4X4 XLT
1997 F250 RC/SB 2WD project
2008 F350 CC/LB 4X4 DRW Lariat, 3" cow catcher mod
2008 Ranger SC FX4
Quote:
Originally Posted by weareweird69 View Post
If your posting pictures bill, everyone dim their screens, that CAT YELLOW is bright
Quote:
Originally Posted by Fordman247365 View Post
Is there anything you DONT take apart and **** with?
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Quote:
Originally Posted by JJFLASH View Post
I still say that those Dodge mirrors have as much business on a OBS Ford as yoga pants have on a fat chick...my .02
alberta 7.3 is offline  
post #3 of 5 Old 11-24-2007, 05:42 PM
Rebel
 
Powerstrokin03's Avatar
 
Join Date: Nov 2007
Location: Indiana
Posts: 657
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Quote:
Originally Posted by alberta 7.3 View Post
Un plug the fuel heater (at bottom of filter bowl) the heater is probably shorted and blowing the fuse
I agree.. Had friend with this problem.
Powerstrokin03 is offline  
post #4 of 5 Old 11-24-2007, 06:24 PM Thread Starter
Powerstroke.org Rookie
 
Join Date: Feb 2007
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Just talked with my bud, he found 2 connectors and disconnected both. FUSE did not blow. He said other connector was about midway up, what does it do? Thanks much
cutty is offline  
post #5 of 5 Old 11-28-2007, 03:42 AM Thread Starter
Powerstroke.org Rookie
 
Join Date: Feb 2007
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Quote:
Originally Posted by alberta 7.3 View Post
Un plug the fuel heater (at bottom of filter bowl) the heater is probably shorted and blowing the fuse
Thanks for info, new part installed. New part has been redesigned with a better element, found defect in old part.
cutty is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome