96 7.3 fluctucating idle, surging WTF..! - Ford Powerstroke Diesel Forum
User Tag List

LinkBack Thread Tools Display Modes
post #1 of 1 Old 11-22-2012, 09:31 AM Thread Starter
Join Date: Nov 2012
Location: Vancouver
Posts: 45
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
96 7.3 fluctucating idle, surging WTF..!

Hi everyone, new here. Someone recommended me to this site to for possible answers.

Anyways, I got a 1996 F350 5speed with 236,000km. It's got a DP Tuner, 3" downpipe, 4inch straight pipe to 5" stack and air intake. I have owned the truck for 2months now and since I bought it I have replaced the alternator and vaccuum pump. One day at an intersection sitting in neutral my idle started to to jump up and down and I thought the truck was going to die.. Did a little research when I got home and discovered our trucks are famous for CPS sensors. So I bought a Borg Warner one and it ran like complete garbage when I installed it. Drove it one block and it started fine, put it in first, ok... then it the rpms just started jumping and the truck was surging i guess you could say. Sorta making me rock back and forth in my seat. Got through 1st to 3rd and it just sucked. Got it back home and put the old sensor back in. Refund! So now here I am a few weeks later and while in 4th gear anywhere between 1400-1600rpm(light throttle just keeping it at 1500rpm) doing 55-65KM/H the rpms jump and truck is surging... Does it also in 5th at 2000rpm 95km/h (this was yesterday and today Nov 20th and 21). So today (21st) I called Bernhausen Diesel (here in Vancouver BC) and told Sat (the owner) what's going on. He told me to remove my tuner and try putting in my new CPS sensor that I bought from Harbour International (after the Borg was crap). So I put the International CPS in and the truck was garbage again. Did not have time to remove my tuner so i'm gonna do that tomorrow. Has anyone ever had this issue or similar? I spoke to BCDiesel also and PDR. All said same thing and all were surprised my truck pretty much rejected the international CPS. I'm quite new to diesels as this is the first one I have owned but I love it already... I hope haha.

Berhausen is so backed up with work and BCDiesel and PDR can't get me in till next week. I can't even the drive the truck anymore without looking like a retard on the road with the fluctuating idle and jumping surging truck while in gear going down the road. I had done a fuel filter too about 900kilometres ago.

I had heard someone had similar issues with a wire touching their valve cover and shorting out.. Checked the wiring and saw nothing touching my valve covers. Injectors now? CPS sensor possibly? Crankshaft? I dunno..
Buckhunter8813 is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome