2000 7.3l. p1670 code. Truck runs rough, lots of white/blueish smoke. - Ford Powerstroke Diesel Forum

 
LinkBack Thread Tools Display Modes
post #1 of 2 Old 11-21-2012, 03:29 PM Thread Starter
Member
 
Armalite's Avatar
 
Join Date: May 2007
Posts: 71
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
2000 7.3l. p1670 code. Truck runs rough, lots of white/blueish smoke.

This is one of our work trucks. I have yet to witness the issue so I am going by what the driver describes.
Basically the truck started missing, lose of power, and white/blue smoke last week. The truck can sit for 20-30 mins and drive fine for another 10mins before these symptoms reoccur. I took a look at it and checked the basics first and ran it for codes. No codes but the fuel filter screen was clogged terribly. Since its a field truck around the yard it seems someone ran off road through it. Our off road tanks don't have external filters. The filter cap screen had a solid layer of rust/dirt/algae and what not on it.
So I let the truck sit for a few days. Today the driver went to use it and the same problems occurred. When he got back I scanned it for a p1670 code. Something to do with the pcm/idm. So after doing research on this code (I didnt clear it) it seems most if not all people with this code have a no start situation. Our truck starts up fine with no excessive cranking etc.
Oil, hpop seem full.... This only happens after about 10 mins of driving/idlin. I was wondering if this possible be a problem with the IPR. I have about 2-3 donor trucks to take on out of.. But they are 97-96 7.3ls. Is there a difference in the sensor from 96-2000? Also any tips on taking it out asap? Dont want to be hung up on this all day tomorrow.
Btw the pigtails on the ICP senor seem clean with no oil or crap in them. I didnt look at the IPR plug tho.
Armalite is offline  
post #2 of 2 Old 11-22-2012, 07:15 AM
Powerstroke.org Rookie
 
Join Date: Nov 2012
Posts: 25
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
i got a similiar prob,(stalls when breaking thred) but no fix yet
ill keep in touch

happy thanksgiving
fairwindracing is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome