95 7.3 - Ford Powerstroke Diesel Forum
User Tag List

LinkBack Thread Tools Display Modes
post #1 of 1 Old 10-19-2012, 03:14 PM Thread Starter
Join Date: Aug 2012
Location: mill creek wva
Posts: 86
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
95 7.3

i need help bad just installed new heads gaskets and everything both sides cause blew drivers side head gasket, figured just get it done since its apart. My problem is this... started it up (took bout 20 minutes of cranking off n on) and now theres antifreeze comin out from behind dust cover of tranny. i mean pouring out got flashlight and crawled under visually checked around heads not comin from there sooooo, my worst fear IS IT CRACKED BLOCK? any suggestions? Thanks in advance guys
cncrestoration is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome