Edge CTS Broke my Truck!! - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 10-19-2012, 06:32 AM
Powerstroke.org Rookie
 

Join Date: Jun 2012
Location: Eagle River AK
Posts: 15
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Edge CTS Broke my Truck!!

I installed my brand new Edge CTS, went to crank her up and nothing.. lights came on.. but when I turned the key.. nothing.. Battery looks good (12.5v), FICM (48v), and I'm not getting any codes.. Anybody have any ideas?
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 10-19-2012, 06:35 AM
Compression Ignition Addict
 

Join Date: Feb 2008
Posts: 8,287
Thanks: 69
Thanked 199 Times in 189 Posts
Feedback Score: 0 reviews
I can't fathom how the CTS would do anything?

you do have the cts power up ,, correct? so that rules out the obd power

you try unhooking it yet?
Reply With Quote Quick reply to this message
  #3  
Old 10-19-2012, 07:47 AM
Powerstroke.org Rookie
 

Join Date: Jun 2012
Location: Eagle River AK
Posts: 15
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I hooked it up to the port under the stearing wheel. The ICP voltage is reading .2v.. Is this too low to run the FICM?
Reply With Quote Quick reply to this message
  #4  
Old 10-19-2012, 08:11 AM
Compression Ignition Addict
 

Join Date: Jul 2012
Location: Portsmouth
Posts: 195
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Try useing a hammer and hiting your starter. If it is not turning over that is where i would start. If your bat. Are at 12.5v


Sent from my iPhone where spell check hates me.
Reply With Quote Quick reply to this message
  #5  
Old 10-19-2012, 03:02 PM
Powerstroke.org Rookie
 

Join Date: Jun 2012
Location: Eagle River AK
Posts: 15
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
starter tested bad, so I replaced it.. still not getting anything when the key turns.. ICP Sensor? it's reading .2v. I was told that the FICM will not kick on if the pressure is too low...

Now I just have to find the damn thing.
Reply With Quote Quick reply to this message
  #6  
Old 10-19-2012, 03:13 PM
Almostdunfukinwidit


 

Join Date: Nov 2006
Location: Trempealeau, WI
Posts: 31,278
Thanks: 122
Thanked 121 Times in 107 Posts
Feedback Score: 0 reviews
Send a message via Yahoo to Dave
Is this an insight CTS or a tuner?

An insight CTS has not effect on tuning.

Your problem is the .2V ICP reading.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 08:44 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors