Low power, cant figure it out - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 10-16-2012, 01:17 PM
Compression Ignition Addict
 

Join Date: Aug 2011
Location: Damariscotta Maine
Posts: 621
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
Low power, cant figure it out

Hey guys, on the way to school today i had an issue, after about 30 mins of driving, assending a decent grade hill truck lost power, big time....was pulling 75 in the fast lane and by the end of it I was the the side of the road trying to keep the truck running, horrible idle and low low power. shut it down, popped hood and fuel pressure looked good, 70psi, started the truck(started hard) and fuel pressure stayed, after idling for a few seconds it smoothed up, so we headed down the road in at attempt to make it to class on time, ran alright for a bit and then started acting up again...we made it and everything was good....on the way home is almost seemed to come out of it and run fine, hasn't caused a problem in probably 25 miles, grabbed a new CPS at napa and will put that in.


Thinking...
cps
or
HPOP related

NOTE* my check engine light doesnt seem to work, it wont illuminate even at start up, so im not sure if it threw a code(stopped in at VIP and they scanned it and said no codes)

but Im not sure if there scanner was compatible.

thanks guys!
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 10-17-2012, 10:37 AM
Compression Ignition Addict
 

Join Date: Aug 2011
Location: Damariscotta Maine
Posts: 621
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
Drove truck around the block trying to simulate results, 15 miles and no problem, but im scared to go on a long trip in fear of it letting me down.

seems to be running fine now.. Icp senser(i think...top of head drivers side) looks clean.

havn't put new cps in yet because i want to have it acting up when i change it, to see if that was the problem.

what other parts of the hpop? maybe it was just a freak thing? but it was bad.
Reply With Quote Quick reply to this message
  #3  
Old 10-18-2012, 11:53 AM
Compression Ignition Addict
 

Join Date: Aug 2011
Location: Damariscotta Maine
Posts: 621
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
Hey guys. drove the truck today about 50 miles, acted fine for the first 30 miles, but then it did it, pulled into closest rest stop and put a new CPS in, didn't change anything at first.....said whatever and continued home, as I pulled out onto the road it came back....ran fine all the way home.

this evening I pulled my fuel pump out due to LOUD opperation, and turns out the pump flows perfectly for 15 seconds then flow starts to drop drastically, so Im sending out for a new pump.


I feel like that isnt my problem though, because the truck was idling like crap, and rev up like crap, but fuel pressure was a solid 70 lbs.

I also unplugged the ICP senser when it started acting up, it changed the tone a little of the motor, but didn't fix it at all. The check engine light came on when I pulled the ICP senser, so I guess my check engine light does work...wonder why it doesnt come on at start up.

thanks guys!
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 02:40 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors