99.5 7.3 passenger bank not working - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 10-03-2012, 01:38 PM
Member
 

Join Date: Jan 2011
Location: Leeds, Alabama
Posts: 43
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
99.5 7.3 passenger bank not working

Update. Solved!
#7 injector had electrical fault that was causing other 3 on passenger bank not to work.
All 4 injectors on each side use a common ground wiring.
When I unplugged #7, --- #5, #3, #1 starting working.
Replaced #7 injector, check engine light is gone, runs great.

It started with a service engine soon light, just started to slow down until it stopped.
Using temp gun I can see drivers side is hitting and passenger is not.
I pulled passenger valve cover checked connection, all connected, change valve cover gasket. Ohm reading from outside valve cover for injectors are all from 2.8 to 3.4.
When you crank it, it sounds great for 5 - 10 seconds and then goes to skipping badly barely running.
Scans and testing have shown very little, #7 injector hi/low open, 1, 3, 5, 7, imbalance. 1316 code has shown up a few times.
Can the IDM fail for one bank only?

Last edited by angcobra; 11-12-2012 at 06:49 AM.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 11:24 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors