95 7.3 Barely runs after oil change - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 09-01-2012, 12:16 PM
Emergency Services
 

Join Date: Jan 2008
Location: College Station, TX
Posts: 558
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
95 7.3 Barely runs after oil change

I've been chasing a pretty decent oil leak and think I traced it to the HPOP o-rings and non-servicable plug. Since I didn't have the parts to fix that today I went ahead and replaced my intake boot (going to turbo) and did an oil change. Used my usual motorcraft dino oil (every 3000-4000 miles) and a motorcraft oil filter like I have for years. Put 15 quarts in, nothing special with this oil change. Now it starts real rough, idles real rough, runs real rough with the gas pedal. Like it's not getting fuel or not enough oil. Any idea whats going on? Could my HPOP be going out? I have replaced fuel pump within the last 1.5-2 years...

This truck will be my main moving truck in 4 days so I need to fix this ASAP!
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 09-01-2012, 03:16 PM
Emergency Services
 

Join Date: Jan 2008
Location: College Station, TX
Posts: 558
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
False alarm guys. UCVH connector broke so 2 cylinders weren't firing I guess. Easily replaced and all is well. Thanks,
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 07:20 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors