95 7.3 Barely runs after oil change - Ford Powerstroke Diesel Forum
 
LinkBack Thread Tools Display Modes
post #1 of 2 Old 09-01-2012, 01:16 PM Thread Starter
Emergency Services
 
TexasAggie09's Avatar
 
Join Date: Jan 2008
Location: College Station, TX
Posts: 558
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
95 7.3 Barely runs after oil change

I've been chasing a pretty decent oil leak and think I traced it to the HPOP o-rings and non-servicable plug. Since I didn't have the parts to fix that today I went ahead and replaced my intake boot (going to turbo) and did an oil change. Used my usual motorcraft dino oil (every 3000-4000 miles) and a motorcraft oil filter like I have for years. Put 15 quarts in, nothing special with this oil change. Now it starts real rough, idles real rough, runs real rough with the gas pedal. Like it's not getting fuel or not enough oil. Any idea whats going on? Could my HPOP be going out? I have replaced fuel pump within the last 1.5-2 years...

This truck will be my main moving truck in 4 days so I need to fix this ASAP!

Thanks and Gig 'Em!
White 1995 F350 CC LB 4x4 7.3 SRW
Bought 8/27/09 with 183k miles
4 Position Chip, 35" BFG Mud Terrains, Bilstein 5125 Shocks, DIY Intake 6637, No cat/muffler, Carr Side Steps, Ranch Hand Front Bumper, Headache Rack, Rear Bumper

Fightin' Texas Aggie Class of 2009


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
TexasAggie09 is offline  
Sponsored Links
Advertisement
 
post #2 of 2 Old 09-01-2012, 04:16 PM Thread Starter
Emergency Services
 
TexasAggie09's Avatar
 
Join Date: Jan 2008
Location: College Station, TX
Posts: 558
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
False alarm guys. UCVH connector broke so 2 cylinders weren't firing I guess. Easily replaced and all is well. Thanks,

Thanks and Gig 'Em!
White 1995 F350 CC LB 4x4 7.3 SRW
Bought 8/27/09 with 183k miles
4 Position Chip, 35" BFG Mud Terrains, Bilstein 5125 Shocks, DIY Intake 6637, No cat/muffler, Carr Side Steps, Ranch Hand Front Bumper, Headache Rack, Rear Bumper

Fightin' Texas Aggie Class of 2009


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
TexasAggie09 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome