99 7.3, intermintant powerloss. Resets with key off. - Ford Powerstroke Diesel Forum
User Tag List

LinkBack Thread Tools Display Modes
post #1 of 2 Old 08-25-2012, 11:49 AM Thread Starter
Powerstroke.org Rookie
Join Date: Jul 2011
Posts: 6
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
99 7.3, intermintant powerloss. Resets with key off.

I have a 99 f250 7.3 manual w/ php 6 pos chip. Couple weeks ago when pull ing out of driveway I lost pedal and it wouldnt rev up. Turned key off and it worked fine again. Last night while getting on highway witht the hammer down it lost all power. I could hardly keep truck going 45 and couldnt get off highway due to construction. I pulled off soon as I could and inspected under hood, no oil or fuel leaks. I limped it to my parents house. I would slightly flash CEL at times but never came all the way on, it had a hard time starting out in first gear at stop lights and would clunk out. It spun and spun and spun and would start again (but I never had key clicked all the way off). I made it to the drive way, shut it off and went in house to get flash light. I came back out started it and it ran fine. Today driving home, same thing getting on onramp (80hp dailydriver tune) with my foot in the pedal lost power, pulled over shut it off to remove key position. It reset and ran fine. I cant recall what tune I was in for the other times it failed but Ive tryed to dupilcate it without success in stock position and in other tunes. Oil has 500 miles on it, newer fuel filter. CPS is about a year old and it s a Ford one, grey if I recall. Im thinking its something electrical due to it resets with key off. Idk if its chip, CPS or bad TPS, truck just turned 300k and I dont know if its ever been replaced. I need to fix this cause its going to happen someplace bad agin like lastnight. Any thoughts?

Last edited by Lowbuckskidoo; 08-25-2012 at 12:21 PM. Reason: update
Lowbuckskidoo is offline  
Sponsored Links
post #2 of 2 Old 08-26-2012, 05:39 AM
Compression Ignition Addict
Join Date: Dec 2009
Location: Monroe, NC
Posts: 170
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 2
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
I have the same issues I have been trying to track down for a while.

when I am going down the road it Will shut off and I Will have to turn the key off and restart/crank the truck while going down the road.
BRAD6160 is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome