Found this in my oil filter housing......PLEASE HELP! - Ford Powerstroke Diesel Forum
User Tag List

Reply
 
LinkBack Thread Tools Display Modes
post #1 of 25 Old 08-06-2012, 11:28 AM Thread Starter
Powerstroke.org Rookie
 
Join Date: Aug 2012
Posts: 16
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Found this in my oil filter housing......PLEASE HELP!

First off the truck is a 2005 F350 6.0 PSD Quad cab Harley Davidson Edition 4x4.

Took the truck to the dealer (Krug Ford Howell Michigan) 4 months ago for the oil leak pass. side and poor fuel economy. They kept it 7 days, killed both my batteries (2 years old sears gold batteries) they said it didnt have a leak they could find and that i needed 2 new batteries. They jump started my truck and gave it back to me with a rip in my drivers leather seat as well. I drove to Advance Auto Parts and bought (2) new batteries. (I'll never give Krug Ford my biz again....maybe not even FORD again because of my experience)


4 months later ...... it dies on my wife with her mom (who is in a wheelchear) on a 95+ day this summer. I drive there and check the oil....its low....i go buy 4 quarts of oil...its takes all of it. (got 5,000 on the oil) Try to start it....just cranks and cranks.....left the truck for a couple hours.....came back wouldnt start after the first few attempts....one last try....bam! she fires up like nothing was wrong. Drove it home with no issues at all. ran like new. Turned it off...restarted no problem. Let it sit for the night, went to start it....crank and crank but no start.
SO.....i call Ford Motor Company and they tell me i'm outta warranty and that my 200,000 mile extended warranty isnt good anymore cuz it expired (even though i only have 189,000 on my truck due to the date. SO i've got a $50,000+ truck sitting in the driveway that i just got for my wife that i have a note on and Ford basicly tells to to "PISS OFF"

Truck sits for 4 months....i keep reading threads on this forum and all of the knowledge...i figure screw it! You guys got my back more that Ford Motor Company so i deceide to tackle the job myself!!

While it was apart i found a torn/falling apart oil cooler screen and IPR screen broken/missing pieces.

I've stripped the engine down to the long block and am replacing all the seals, EGR delete, Upgraded oil cooler, upgraded turbo drain back tube,STC fitting, stand pipes, dummy plugs, IPR, ICP/ pigtail and Doing ARP head studs (one at a time since it has only 20-30k since FORD replaced the heads) oh...and its getting a K&N cold air intake and SCT tuner.

This is my problem.....pulled the Oil filter housing off and found these plastic pieces sitting in the bottom :
(diffent angle same pieces)

(different angle...same pieces:



I have no idea what they are...where they came from??
I'm getting close to putting the truck back together but need to know if anyone has seen something like this. If not...how did it get there? Dip**** Ford Mechanic drop something in there? ( You wouldnt believe it...FORD ASE mechanic left a intake bolt loose...had RTV on the rubber seal to the oil pump cover too, left the valley a total mess...you name it!)




To my Belief I think the no start condition was caused by the Ford tech. not cleaning the valley and debris getting into the Oil cooler and IPR, also the STC fitting was the upgraded one with the bracket but seemed like the bracket did more harm than good IMO.

I also want to add that my Antifreeze looked like brand new and oil was black like diesel oil should be. Degris bottle was a little low but clean as a whistle.

Anyways.....Help is greatly appreciated!!

Last edited by fiveohcrazy; 08-06-2012 at 11:53 AM.
fiveohcrazy is offline  
post #2 of 25 Old 08-06-2012, 11:31 AM
,,,,,,,,,,,,,,,,,,,,,,,,,
 
ZMANN's Avatar
 
Join Date: Feb 2008
Posts: 14,484
Mentioned: 51 Post(s)
Tagged: 0 Thread(s)
Quoted: 546 Post(s)
Thanks: 498
Thanked 696 Times in 663 Posts
Feedback Score: 0 reviews
OEM filter?


.
.
.
Please donate to DTR Ron's Memorial
https://www.gofundme.com/2464axqr
We Miss you Ronnie
RIP
ZMANN is offline  
post #3 of 25 Old 08-06-2012, 11:59 AM Thread Starter
Powerstroke.org Rookie
 
Join Date: Aug 2012
Posts: 16
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I had a WIX filter and cap on it but have since reading all the threads about aftermarket filters i got a OEM Cap and Filter to go back in.
fiveohcrazy is offline  
post #4 of 25 Old 08-06-2012, 12:03 PM
,,,,,,,,,,,,,,,,,,,,,,,,,
 
ZMANN's Avatar
 
Join Date: Feb 2008
Posts: 14,484
Mentioned: 51 Post(s)
Tagged: 0 Thread(s)
Quoted: 546 Post(s)
Thanks: 498
Thanked 696 Times in 663 Posts
Feedback Score: 0 reviews
WOW you edited your original post with a lot more info ,,,, I have to go back and reread LOL


Chit filters .. the only thing else would be check the drain back valve at the bottom (it lets the oil drain when the cap is unscrewed and relieves the pressure the filter is pushing on it .. also their is a plastic piece at the top of the tower

make sure everything looks OK I don't recognize any of your debris ,, but I haven't ever looked real hard at the tower (stalk )

.
.
.
Please donate to DTR Ron's Memorial
https://www.gofundme.com/2464axqr
We Miss you Ronnie
RIP
ZMANN is offline  
post #5 of 25 Old 08-06-2012, 12:06 PM Thread Starter
Powerstroke.org Rookie
 
Join Date: Aug 2012
Posts: 16
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
The drainback valve is in perfect shape and seems to operate like it should. I even pulled it out and checked to make sure nothing was in it.
fiveohcrazy is offline  
post #6 of 25 Old 08-06-2012, 12:07 PM
,,,,,,,,,,,,,,,,,,,,,,,,,
 
ZMANN's Avatar
 
Join Date: Feb 2008
Posts: 14,484
Mentioned: 51 Post(s)
Tagged: 0 Thread(s)
Quoted: 546 Post(s)
Thanks: 498
Thanked 696 Times in 663 Posts
Feedback Score: 0 reviews
Uhm you should have learned you lesson on filters with this

cancel the intake K&N filter or save for a replacement turbo

.
.
.
Please donate to DTR Ron's Memorial
https://www.gofundme.com/2464axqr
We Miss you Ronnie
RIP
ZMANN is offline  
post #7 of 25 Old 08-06-2012, 12:13 PM Thread Starter
Powerstroke.org Rookie
 
Join Date: Aug 2012
Posts: 16
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I'll keep it oiled all the time and clean it often. most guys dont like their trucks like i like mine
fiveohcrazy is offline  
post #8 of 25 Old 08-06-2012, 12:47 PM
,,,,,,,,,,,,,,,,,,,,,,,,,
 
ZMANN's Avatar
 
Join Date: Feb 2008
Posts: 14,484
Mentioned: 51 Post(s)
Tagged: 0 Thread(s)
Quoted: 546 Post(s)
Thanks: 498
Thanked 696 Times in 663 Posts
Feedback Score: 0 reviews
it won't matter they are no good

even on a gasser they dust the MAF sender
I had two identical units and the K&N had a dirty intake past the filter

as far as the 6.0 K&N is a wide spread NO NO and if you start a thread about it you
will be able to validate what I am preaching .. or a Google search will probably have the same out come

.
.
.
Please donate to DTR Ron's Memorial
https://www.gofundme.com/2464axqr
We Miss you Ronnie
RIP
ZMANN is offline  
post #9 of 25 Old 08-06-2012, 01:02 PM Thread Starter
Powerstroke.org Rookie
 
Join Date: Aug 2012
Posts: 16
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by ZMANN View Post
it won't matter they are no good

even on a gasser they dust the MAF sender
I had two identical units and the K&N had a dirty intake past the filter

as far as the 6.0 K&N is a wide spread NO NO and if you start a thread about it you
will be able to validate what I am preaching .. or a Google search will probably have the same out come


I'll check into it for sure...thx for the heads up.
fiveohcrazy is offline  
post #10 of 25 Old 08-06-2012, 01:08 PM
Powerstroke.org Fanatic
 
mantis118's Avatar
 
Join Date: Mar 2012
Location: Nederland Tx
Posts: 102
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I have a k&n. Never had an issue. Had them on every vehicle I've owned.

03 F250XL- full exhaust, fuel lab fuel system, on board air, cold air, an TS 6 pposition chip

12 Boss 302- twin 60s, full suspension, working on 6r80 swap
mantis118 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome