cooling fans staying on - Ford Powerstroke Diesel Forum
User Tag List

LinkBack Thread Tools Display Modes
post #1 of 1 Old 07-17-2012, 09:15 AM Thread Starter Rookie
Join Date: Oct 2009
Posts: 20
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
cooling fans staying on


Got a 2008 6.4l in the shop that has the cooling fans staying on all the time. If you unplug them they shut off so clutch is working. Got it on the scanner and the only fault I found was the transmission over temperature lockup had a fault in the pid's. Would this cause the fans to run all the time? If so what is this fault? is it a sensor or the temperature sensor reading wrong? the temp sensor shows good tranny temp so not sure. PLEASE HELP!!! This truck is annoying!!!
Raising Hell is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome