battery drain / glow plug relay - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 07-09-2012, 07:17 PM
Powerstroke.org Rookie
 

Join Date: Jul 2012
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
battery drain / glow plug relay

hey guys, i am on vacation with my family and my early 99 ps 6spd dually is draining the batteries. got dark on me tonight before i got it tracked down but i noticed when i put the positive battery cables on the batteries there is an arc. i dont mean a spark, i am talking about it looks as if the cable is gonna weld to the terminal. i pulled the altrnator wires, starter, ect then pulled th wsire off the starter relay and killed the arc. that wire goes to the glow plug relay. i then hookd it back up and pulled the brown and yellow? wires off the relay and tried again and the arc stopped. it got dark before i got any further. are those brown and yellow wires feeds for the glow plugs? i did pull the injector harness's off the vc gaskets one at a time but the arc was still there. this is all with the key off. any ideas on what could be causing this? short in one of those two wires? gpr stuck on? i am assuming this arc has something to do with my battery drain. i apreciate your replies!
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 07-09-2012, 07:21 PM
Compression Ignition Addict
 

Join Date: Feb 2009
Location: Nacogdoches, TX
Posts: 11,061
Thanks: 0
Thanked 13 Times in 13 Posts
Feedback Score: 0 reviews
Personally, I'd just undo the GPR connections and tape it all up if that stops the arc, and figure it out later once you're back home. I doubt you'll need the GPs right now this time of year.
Reply With Quote Quick reply to this message
  #3  
Old 07-10-2012, 03:22 AM
Powerstroke.org Rookie
 

Join Date: Jul 2012
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
thanks for the reply.

i do think that relay is sticking open. with the key off i had power on both big terminals then tapped on the relay and i heard it click, then i only had power on the input.
Reply With Quote Quick reply to this message
  #4  
Old 07-10-2012, 04:12 AM
Compression Ignition Addict
 

Join Date: Feb 2009
Location: Nacogdoches, TX
Posts: 11,061
Thanks: 0
Thanked 13 Times in 13 Posts
Feedback Score: 0 reviews
Yea, that would be sticking
Where you live?
Reply With Quote Quick reply to this message
  #5  
Old 07-10-2012, 08:08 AM
Powerstroke.org Rookie
 

Join Date: Jul 2012
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Arkansas. i put a relay on it this morning, i think all is good.
Reply With Quote Quick reply to this message
  #6  
Old 07-10-2012, 02:36 PM
Compression Ignition Addict
 

Join Date: Feb 2009
Location: Nacogdoches, TX
Posts: 11,061
Thanks: 0
Thanked 13 Times in 13 Posts
Feedback Score: 0 reviews
I was gonna say, not like you'd need it anytime soon, but hope it works for ya.
Reply With Quote Quick reply to this message
  #7  
Old 07-26-2012, 02:05 PM
Powerstroke.org Rookie
 

Join Date: Jul 2012
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
My father-in-law is having the same problem with his 97 f250. he replaced the solenoid on top of the engine but its draining the batt's relly fast. could it be the relay, and where is this relay. or could it be something diffrent. We did notice the volt meter is no showing a full 12 volts. Checked the alt but its good. Please help i'm lost on this one.
Reply With Quote Quick reply to this message
  #8  
Old 07-26-2012, 03:51 PM
Compression Ignition Addict
 

Join Date: Feb 2009
Location: Nacogdoches, TX
Posts: 11,061
Thanks: 0
Thanked 13 Times in 13 Posts
Feedback Score: 0 reviews
What solenoid relay you talking? btw
Reply With Quote Quick reply to this message
  #9  
Old 07-29-2012, 02:27 PM
Powerstroke.org Rookie
 

Join Date: Jul 2012
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
It is the Glow plug relay. I have all the wires off of the gpr and its still pulling the battery down.
Reply With Quote Quick reply to this message
  #10  
Old 07-30-2012, 11:41 AM
Compression Ignition Addict
 

Join Date: Feb 2009
Location: Nacogdoches, TX
Posts: 11,061
Thanks: 0
Thanked 13 Times in 13 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by Preach65 View Post
It is the Glow plug relay. I have all the wires off of the gpr and its still pulling the battery down.
If all wires are off it, then it can't be the issue

I made my Samsung SGH-I997 send this.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 07:23 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors