Help! Loss of power without coolant loss, runs rough. - Ford Powerstroke Diesel Forum
User Tag List

LinkBack Thread Tools Display Modes
post #1 of 2 Old 07-08-2012, 03:17 PM Thread Starter Rookie
maladosteo's Avatar
Join Date: Jul 2010
Posts: 26
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Help! Loss of power without coolant loss, runs rough.

Just got back from vacation down to Wilmington towing the 5th wheel (@12k). Dropped it off at storage and started to drive home and had some loss of power. The farther I went, the more power I lost and the rougher it ran. I pulled over at a gas station and checked it out. I had no blown IC boots, no puking from the Degas bottle, the coolant was at the recommended sticker level. I limped it to the nearest Autozone and had them check it out with their little scan tool and it showed no codes...
I "think" i may have a bad injector, but I have no way of knowing. I don't think their scan tool had the capability to see what's really going on...
Any help or guidance would be greatly appreciated!!!

2005 F-250 Lariat CC FX4 4WD, fixed FICM ( w/ PHP Atlas 40, DC Power 185 amp alternator, MBRP 5 inch Turbo back, IPR EGR Delete, IPR Up=pipe, '08 banjo bolt mod, Blue Spring Regulator mod, AMSOIL oil bypass filter, Dieselsite Coolant bypass filter, Zoodad mod, High idle mod, CCV mod, Rotella T6 5w-40, Recon Blacked out third brake light/ side mirror turn signals, 7in Screen Double Din AM/FM/CD/DVD/ iPod ctrl/ NTSC TV eBay special, Rear 56" 5 way light bar
maladosteo is offline  
Sponsored Links
post #2 of 2 Old 07-09-2012, 01:52 PM
Compression Ignition Addict
rjm0027's Avatar
Join Date: Jan 2009
Location: Central PA
Posts: 257
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
same type of thing happened to me, mine is blowing white smoke though in addition, still at the garage waiting on them to figure out what the heck it is, they ran an injector buzz test and it was normal, checked the fuel, it was good. I have no idea what it is, also have no codes

2003 F250 7.3L ECLB
rjm0027 is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome