2004 6.0 LOSS OF POWER AFTER EGR DELETE - Ford Powerstroke Diesel Forum
 
LinkBack Thread Tools Display Modes
post #1 of 4 Old 04-05-2012, 05:03 AM Thread Starter
Powerstroke.org Rookie
 
Join Date: Jul 2008
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
2004 6.0 LOSS OF POWER AFTER EGR DELETE

I have a 2005 Excursion, build date on 6.0 is 2004. After an EGR delete, the truck has no power. Old version of Bully dog tuner was replaced with an SCT. After tuning the truck (with either tune) when we drive the truck, it has an appx 50% power loss the first time you get on the truck, after the 1st time, or 2nd time, it looses power and runs like a stock 6.0. We have checked fuel pressure, replaced FICM, ICP, MAP and any other sensor that we could to try and resolve. Worked with SCT for a long time, checked everything on programmer and it is fine, again, this issue only started after the EGR was deleted. Any ideas?
coilover superduty is offline  
post #2 of 4 Old 04-05-2012, 05:31 AM
Premium Member
 
Term3's Avatar
 
Join Date: Feb 2011
Location: Edmonton, Alberta Canada
Posts: 3,957
Thanks: 0
Thanked 34 Times in 32 Posts
Mentioned: 0 Post(s)
Quoted: 1 Post(s)
Feedback Score: 1 reviews
My '05 Ex has an EGR delete and my power is fine and with a programer REL fine. I'm wondering if you still have your EGR valve still plugged in as their are issues if it isn't.

SCT, no studs...yet, Dual OEM intake air filter housings, Banks intercooler & intake elbow, Banks exhaust system, Windrunner ported intake manifold, Bullet Proof Diesel remote oil cooler & thermostat, AirDog2 (plus a couple spares), Power steering filter (Amsoil dual-bypass), MagTec deep ATF pan, Electric oil pre-lub pump, Dakota Digital gauges.
Term3 is offline  
post #3 of 4 Old 04-05-2012, 07:28 AM Thread Starter
Powerstroke.org Rookie
 
Join Date: Jul 2008
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Quote:
Originally Posted by Term3 View Post
My '05 Ex has an EGR delete and my power is fine and with a programer REL fine. I'm wondering if you still have your EGR valve still plugged in as their are issues if it isn't.
Thanks, we checked all electrical plugs, all good.
coilover superduty is offline  
post #4 of 4 Old 04-05-2012, 07:41 AM Thread Starter
Powerstroke.org Rookie
 
Join Date: Jul 2008
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
We checked all plugs and found no issues, thanks for trying.
coilover superduty is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome