Need advice on a 6.0 Power Headach! - Ford Powerstroke Diesel Forum
 
LinkBack Thread Tools Display Modes
post #1 of 1 Old 03-28-2012, 02:49 PM Thread Starter
Powerstroke.org Rookie
 
Join Date: Mar 2007
Location: Ohio
Posts: 18
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Question Need advice on a 6.0 Power Headach!

I have a 2005 F450 6.0.I January it just quit and would not start. Had it towed to a mechanic. He changed the IRP sensors, and it was fine ran great until 2 weeks ago. Once again towed it to the garage. We tried a new sensor but computer said we were only getting 145 psi out of the HPOP. Mechanic said well Ford had problems with that pump. Said fine put in a new one. Also had the oil cooler changed and Did a EGR Delete while he had it a part. All back to gather cranked it, Still only 145 psi from the HPOP. Checked the low pressure pump and its fine. So onward we go. We replaced the D plugs in the HPOP rail for the injectors and new improved stand pipes from Ford. Again cranked it and still only 145 PSI out of the HPOP. Anybody got any ideas. Redone the HPOP system from end to end and still have this problem. Mechanic is now suggesting Injectors. I don't want to guess at 1700.00 dollars worth of injectors.

Help
b2zone is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome