Truck shut off while driving, trying to narrow it down - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 03-18-2012, 08:39 PM
Powerstroke.org Rookie
 

Join Date: Jan 2010
Posts: 15
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Truck shut off while driving, trying to narrow it down

While returning from the park with family truck was nice enough to shut off and leave me on side of the road. 2003 6.0

Here is what I know:
FICM voltage is great
Truck restarted 2 hours later and immediately shut off.
I get code 2623 Injector control pressure regulator open circuit
Oil gauge does work while cranking
ICP voltage is .1 key on .3-4 while cranking

Here is where I am at.. Do I buy a new IPR? Or ICP? I am going to pull IPR tomorrow and inspect screen. But I hear ICP could be issue too...


Anyone have insight, I need this truck running.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 03-19-2012, 03:59 PM
Powerstroke.org Rookie
 

Join Date: Jan 2010
Posts: 15
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Fixed problem. The wires on the IPR had no insulation left from heat and they were shorting out. Applied tape put everything back together Truck runs like a champ. Now I have to find a new connector before bandaid fails.
Reply With Quote Quick reply to this message
  #3  
Old 03-19-2012, 04:02 PM
Premium Member



 

Join Date: Dec 2011
Location: Spokane, WA
Posts: 18,138
Thanks: 74
Thanked 121 Times in 112 Posts
Feedback Score: 5 reviews
Great
Reply With Quote Quick reply to this message
  #4  
Old 04-02-2012, 06:12 PM
Member
 

Join Date: Mar 2012
Posts: 55
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by nelapse View Post
Fixed problem. The wires on the IPR had no insulation left from heat and they were shorting out. Applied tape put everything back together Truck runs like a champ. Now I have to find a new connector before bandaid fails.
I was going to suggest that. My 96 did the exact same thing 4 years ago. Glad you got it fixed.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 03:06 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors