07 f-350 6.0 died - Ford Powerstroke Diesel Forum
User Tag List

LinkBack Thread Tools Display Modes
post #1 of 1 Old 02-22-2012, 05:28 PM Thread Starter
Powerstroke.org Fanatic
Join Date: Feb 2012
Location: santa clara
Posts: 132
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
07 f-350 6.0 died

only 89k, had a bad lag on accel shut off would not start back up, let it sit and started fine, checked codes and nothing but a turbo low boost showed up, was going to take it to a dealer to try there scanner but it died and would not start on the way home, I had the same problem back when it was under warranty and the dealer said after two weeks that the injector harness had burned on the manifold. and that was only about 7k ago. Any one have the same type of issue I know it is probably posted here already but I need to be pointed in the wright direction. Thanks for any info. forgot to mention the scanner said I had 500psi at idle and it went up when reeving up the engine.

Last edited by shadyford; 02-22-2012 at 06:15 PM.
shadyford is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome