2005 E350 help needed asap - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 08-29-2007, 02:22 PM
Member
 

Join Date: Jul 2007
Location: Temple,Ga
Posts: 52
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
2005 E350 help needed asap

My 05 E350 has a 6.0 psd and this morning it had problems cranking.well i changed the oil today and just drove it 40 miles and had to come back to my jobsite and when i got here and shut it off...and went to start it back up and all it will do is turn over.i have tried to crank it 10-15 times over the last half hour and it just spins.......im stuck here 100 miles from home and need some suggestions.


there are no codes or CEL being thrown either


thanks
Brian
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 08-29-2007, 02:27 PM
Compression Ignition Addict
 

Join Date: May 2007
Location: America
Posts: 6,783
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
Do you have enough oil? Are any fuses blown? Are you sure its your van?

Last edited by 2005F250; 08-29-2007 at 02:28 PM. Reason: Forgot an n.
Reply With Quote Quick reply to this message
  #3  
Old 08-29-2007, 02:53 PM
Member
 

Join Date: Jul 2007
Location: Temple,Ga
Posts: 52
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
oil is good.fuses are good,its my van
Reply With Quote Quick reply to this message
  #4  
Old 08-29-2007, 03:07 PM
ADMIN AND TECH


 

Join Date: Oct 2006
Location: winston salem north carolina
Posts: 9,241
Thanks: 0
Thanked 4 Times in 4 Posts
Feedback Score: 0 reviews
being that it is a 05 model if i had to guess , there are two things ive been seeing alot of on the vans , why the vans i dont know , but on the right side of the engine in the oil rail to the injectors there is a plug , there are two o-rings on this plug , the bottom one has been blowing out , like i said i dont know why on a van , but ive had six in three months with no high pressure opil and that is what i found , maybe the extra heat, i dont know , but the other thing is the high pressure oil pump fitting blowing out , the only thing that doesnt make since is you say you dont have any codes , is the scanner your using able to pull the cods correctly for this 6.0 engine , some scanners will pull generic codes but wont allow you to pull ford specific codes , only other thing thats possible would be fuel pressure , i have replaced a few fuel pumps , make sure pump is running , im curious what it turns out to be so keep us informed
Reply With Quote Quick reply to this message
  #5  
Old 08-30-2007, 02:19 AM
Member
 

Join Date: Jul 2007
Location: Temple,Ga
Posts: 52
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Im sending it to ford this morning.I will let you know what it is.thanks guys
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 08:09 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors