What is wrong with my 7.3? - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 09-12-2011, 05:40 PM
Powerstroke.org Fanatic
 

Join Date: Aug 2009
Posts: 140
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
What is wrong with my 7.3?

Some background..2001 excursion 115k miles cp chip mbpr exhaust banks turbo....
Labor day weekend taking the fam camping (first time with this truck). My f150 pulls our trailer no prob, anyway the truck is struggling egt is pretty high, we stop for a short break (truck does not get shut off) go on our merry way and 2 mies down the highway just dies...cranks ,no start, no check engine light...nothing. So I try a few simple fixes including a cps to no avail. Take it to the shop they tell me no injector pressure replace the IPM and the ICP and viola we are on the road again...for a day. Driving normally and it dies again, pop it in nuteral and it fires right back up...take it back to the shop immediately and they tell me cps I say I just did one they tell me needs to be a ford part (no a ford shop). Ok so they do it all dandy again for a day drove it this morning no problems, fire it up this afternoon drive about a quarter mile and the rpm's drop like a rock and it is struggling, flip the chip to high idol and it can't even push past 1000 rpms. Finally it breaks loose, I drive to where i need to go and the truck sits running for about 30 minutes. On the way home get about a mile down the road and the rpms drop again...get it semi normal again and head for home...2 miles later I am limping egt is 900-100 trans temp is about 190 and if I try to go any faster than 10 mph the thing sounds like it's gonna fall apart....any ideas what the heck is going on?
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 09-12-2011, 06:10 PM
Compression Ignition Addict
 

Join Date: Feb 2009
Location: Nacogdoches, TX
Posts: 11,055
Thanks: 0
Thanked 12 Times in 12 Posts
Feedback Score: 0 reviews
Check the UVCH and connections.
By IPM you mean IPR maybe? And what else did he say other than no injector pressure? Did he even know what he was talking about?
Reply With Quote Quick reply to this message
  #3  
Old 09-12-2011, 06:17 PM
Compression Ignition Addict
 

Join Date: Jul 2008
Location: Wake Forest, NC
Posts: 4,088
Thanks: 25
Thanked 28 Times in 26 Posts
Feedback Score: 0 reviews
Check the wires also going to the icp. Did u by the truck new or used? I had a bad wire going to my icp and had lots of issues. Even showed no injector pressure while the truck was running.

Sent from my fone.
Reply With Quote Quick reply to this message
  #4  
Old 09-12-2011, 06:23 PM
Powerstroke.org Fanatic
 

Join Date: Aug 2009
Posts: 140
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
My fault injector pressure regulator..beyond the injector pressure he said they had read some codes during the first repair..sadly I was preoccupied by my 1 y.o and did not hear him. I bought the truck used a month and a half ago I had no issues before this crash...another trigger that may have (just grasping at straws here) had a DVD system and head unit installed the week before. The mech told me the ipr was a separate system so the chances of that screwing it up were slim. This mech came highly recommended by someone who's opinion on this I very much respect and happens to drive a 7.3 owner too....can you point me to the uvch?
Reply With Quote Quick reply to this message
  #5  
Old 09-12-2011, 06:48 PM
Compression Ignition Addict
 

Join Date: Feb 2009
Location: Nacogdoches, TX
Posts: 11,055
Thanks: 0
Thanked 12 Times in 12 Posts
Feedback Score: 0 reviews
Yea doubt that DVD cause it.
Belz is right about the IPR.
There is a plug going into each valve cover, about in the center, with 8 pins each. 4 for glow plugs, 4 for injectors. Check to make sure the connection is tight and that none of the pins are burnt.
Reply With Quote Quick reply to this message
  #6  
Old 09-13-2011, 03:42 AM
Powerstroke.org Fanatic
 

Join Date: Aug 2009
Posts: 140
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by jesilvas View Post
Yea doubt that DVD cause it.
Belz is right about the IPR.
There is a plug going into each valve cover, about in the center, with 8 pins each. 4 for glow plugs, 4 for injectors. Check to make sure the connection is tight and that none of the pins are burnt.
Icp or ipr? I checked the ipr plug on the drivers side is there another one?
Reply With Quote Quick reply to this message
  #7  
Old 09-13-2011, 06:14 AM
Compression Ignition Addict
 

Join Date: Jul 2008
Location: Wake Forest, NC
Posts: 4,088
Thanks: 25
Thanked 28 Times in 26 Posts
Feedback Score: 0 reviews
Mine was wire going to icp. Truck would start stumbling and I would lose throttle response at random. Sometimes it would shut off others it wouldn't. I got to the point where I would shut it off and crank it back up rolling done the road. It was easier than trying to stop with the truck off.


Sent from my fone.
Reply With Quote Quick reply to this message
  #8  
Old 09-13-2011, 02:56 PM
Compression Ignition Addict
 

Join Date: Feb 2009
Location: Nacogdoches, TX
Posts: 11,055
Thanks: 0
Thanked 12 Times in 12 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by macsdaddy View Post
Icp or ipr? I checked the ipr plug on the drivers side is there another one?
Meant the UVCH
Reply With Quote Quick reply to this message
  #9  
Old 09-13-2011, 06:04 PM
Powerstroke.org Fanatic
 

Join Date: Aug 2009
Posts: 140
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Well after a day at the shop the tech told ke it's thrown number of codes that he's gonna asses and troubleshoot in the morning...grr
Reply With Quote Quick reply to this message
  #10  
Old 09-13-2011, 06:21 PM
Compression Ignition Addict
 

Join Date: Feb 2009
Location: Nacogdoches, TX
Posts: 11,055
Thanks: 0
Thanked 12 Times in 12 Posts
Feedback Score: 0 reviews
Could you list what codes?
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 03:33 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors