No Power to FUEL PUMP - Ford Powerstroke Diesel Forum
LinkBack Thread Tools Display Modes
post #1 of 2 Old 08-03-2007, 10:09 PM Thread Starter Rookie
Join Date: Jul 2007
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
No Power to FUEL PUMP

Where is the fuel pump relay on my 1999 F350 7.3liter that was manufactured in 11/88? I am not receiving any power to the pump via the factory wires. The fuse (#19) is good under the hood and has power. My Tach is working also. I am getting sick of this truck... I really mean it!

Last edited by overdalimit; 08-03-2007 at 10:13 PM.
overdalimit is offline  
post #2 of 2 Old 08-04-2007, 08:52 AM
Compression Ignition Addict
lilredpowerstroke's Avatar
Join Date: Nov 2005
Location: Big Cypress Indian Reservation
Posts: 2,756
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Bump to the top.

2003 F-350 dually 6.0
Centennial Edition
Straight exhaust 34x10.50 Swampers on Black Rock Stars

Been a member longer than most of the moderators
Thats why I said most Tiff

Think you can trust the government? Ask an American Indian!

My old truck in action
lilredpowerstroke is offline  

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome