Stumped... - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 07-09-2007, 08:02 PM
Emergency Services
 

Join Date: May 2007
Location: Columbus, OH
Posts: 5,538
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Send a message via AIM to cchase
Stumped...

I have a 99.5 7.3L and it runs rough on start up with the check engine light on. It all goes away when the truck warms up. I just replaced the CPS and all it did was go away for a few minutes then come right back. I cant get it to read any codes, and I am reluctant to take it to my local ford dealer because they always give me the run around. What do I do next?
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 07-10-2007, 06:00 AM
Thats Mr. Oil Leak.....

 

Join Date: Oct 2006
Location: Cypress / Houston
Posts: 9,526
Thanks: 4
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Send a message via AIM to MrJohnWayne Send a message via MSN to MrJohnWayne Send a message via Yahoo to MrJohnWayne
Not sure but here is a bump
Reply With Quote Quick reply to this message
  #3  
Old 07-10-2007, 06:08 AM
duct tape & zip ties

 

Join Date: Jul 2006
Location: Willis, MI
Posts: 10,759
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Send a message via Yahoo to bigcountrysg
Take it to a diesel repair shop. Let them use there high dollar equipment to get codes for you. Unless you have a program like auto enginuity or a highdollar scanner you most likely will not get any codes. Being the cel is going off on its own. It would be considered a soft code. Most code scanners will not read these or detect them.

I could speculate that it is a fuel problem, or injector problem. Which when the engine is warm goes away.
Reply With Quote Quick reply to this message
  #4  
Old 07-10-2007, 06:27 AM
ADMIN AND TECH


 

Join Date: Oct 2006
Location: winston salem north carolina
Posts: 9,208
Thanks: 0
Thanked 4 Times in 4 Posts
Feedback Score: 0 reviews
sounds like under valve cover wiring , possibly , if you dont want to take it in may want to remove valve covers and look, but it still should have set a code in memory
Reply With Quote Quick reply to this message
  #5  
Old 07-10-2007, 09:36 AM
Serving Our Country!
 

Join Date: May 2007
Location: Mountain Home Idaho
Posts: 50
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Try removing the edge module. I am not sure if it is a problem on the fords but I have seen problems with them on the chevy.
Reply With Quote Quick reply to this message
  #6  
Old 07-10-2007, 07:04 PM
Emergency Services
 

Join Date: May 2007
Location: Columbus, OH
Posts: 5,538
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Send a message via AIM to cchase
I have an update. I changed the CPS and now the CEL doesnt come on intill about 2 minutes after its running, but it now longer goes off when truck warms up, but it will go off for a few minutes then come back on... Maybe I will just have ford run the scanner and see what codes it is giving. unless anyone knows a good diesel shop in the cleveland, oh area
Reply With Quote Quick reply to this message
  #7  
Old 07-10-2007, 07:13 PM
Serving Our Country!
 

Join Date: Feb 2006
Location: Mid Michigan
Posts: 244
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Send a message via Yahoo to worx
If you have to take it to a shop, I don't know any performance ones, but they have a good tech at Mike Bass Ford in Lorain- I ended up getting towed there when my IPR went out and they were good to me... not cheap though, but good guys... almost had a PDA with plug and software- but I was nice and took it back in to them before I left...
The guys up front are the commercial truck service garage- they do the PSDs, the back is the car dealers- they are clueless...
Reply With Quote Quick reply to this message
  #8  
Old 07-10-2007, 07:46 PM
Emergency Services
 

Join Date: May 2007
Location: Columbus, OH
Posts: 5,538
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Send a message via AIM to cchase
Great Thanks. I will give them a try tomarrow, they tried ripping me off before but it was bareings and it was the back shop. So I will give the front a try. Thanks for the help
Reply With Quote Quick reply to this message
  #9  
Old 07-10-2007, 07:58 PM
Compression Ignition Addict
 

Join Date: Apr 2007
Posts: 1,479
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Before you spend money, did you try removing the Juice? Seems like you'd want to try the free thing first...
Reply With Quote Quick reply to this message
  #10  
Old 07-11-2007, 10:41 AM
Emergency Services
 

Join Date: May 2007
Location: Columbus, OH
Posts: 5,538
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Send a message via AIM to cchase
Why would the edge cause problems now, when I have been running it for months? or does the edge just suck. I have had it set on 0 which is stock and no difference.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 01:14 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors