Truck wont start after pyro install - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 06-24-2007, 07:29 PM
Member
 

Join Date: Oct 2006
Location: High Desert
Posts: 66
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Truck wont start after pyro install

help truck wont start.....

i just hooked up my pyro gauge and now truck alarm jsut goes crazy when i stick my key in.... it was saying TBC fault but i unhooked the batts and plugged everything back in but still honks when i put the key in ... pump comes on, but glow light in dash never comes on and it just clicks from somewhere in the dash when you try to crank it...anybody please help
__________________
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 06-24-2007, 08:09 PM
Compression Ignition Addict
 

Join Date: Nov 2005
Location: Big Cypress Indian Reservation
Posts: 2,756
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Did you cbeck all the fuses??
Reply With Quote Quick reply to this message
  #3  
Old 06-24-2007, 08:15 PM
Compression Ignition Addict
 

Join Date: May 2007
Location: America
Posts: 6,783
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Uh sh!t. Did you use a test light and cycle the ignition to make sure it was was only hot when the ignition is on. I spliced mine into a wire near the TBC but not on the TBC itself. As long as you spliced and didn't cut you can cut the pyro wires and deal with it later. I was having problems with mine and I gave it a day before going back to it and all that was wrong is that I had a bad ground.
Reply With Quote Quick reply to this message
  #4  
Old 06-24-2007, 08:17 PM
Compression Ignition Addict
 

Join Date: May 2007
Location: America
Posts: 6,783
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
And for the horn there is a wire that if it you ground it it will honk. The first time it happened to me it scared me and I hit my head.
Reply With Quote Quick reply to this message
  #5  
Old 06-24-2007, 09:42 PM
Member
 

Join Date: Oct 2006
Location: High Desert
Posts: 66
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
no everything on the pyro is hooked near the light switch and i cycled key too.. i got good grounds..i will check the fuses tomorrow it seems like some sort of alarm problem...


it is still reading TBC fault.... what is the TBC???


horn honks like the chirp but just wont stop every time i touch the truck now...


everything is back together and all works fine except alarm and it wont start or even crank....


truck is still programmed and i checked for codes and there wasnt any... im lost
Reply With Quote Quick reply to this message
  #6  
Old 06-24-2007, 09:55 PM
Member
 

Join Date: Oct 2006
Location: High Desert
Posts: 66
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by gobigorgohome View Post
no everything on the pyro is hooked near the light switch and i cycled key too.. i got good grounds..i will check the fuses tomorrow it seems like some sort of alarm problem...


it is still reading TBC fault.... what is the TBC???


horn honks like the chirp but just wont stop every time i touch the truck now...


everything is back together and all works fine except alarm and it wont start or even crank....


truck is still programmed and i checked for codes and there wasnt any... im lost
TBC- Trailer Brake Control --
Reply With Quote Quick reply to this message
  #7  
Old 06-25-2007, 10:42 AM
Member
 

Join Date: Oct 2006
Location: High Desert
Posts: 66
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
fixed it

couple blown ignition fuses, which was making my alarm go nuts
Reply With Quote Quick reply to this message
  #8  
Old 06-26-2007, 07:10 PM
Compression Ignition Addict
 

Join Date: Nov 2005
Location: Big Cypress Indian Reservation
Posts: 2,756
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Glad you got it goin again.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 07:31 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors