7.3 Turbo intercooling tube - Ford Powerstroke Diesel Forum

 
LinkBack Thread Tools Display Modes
post #1 of 2 Old 10-04-2010, 07:31 AM Thread Starter
Powerstroke.org Rookie
 
Join Date: Sep 2010
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
7.3 Turbo intercooling tube

Help, the intercooling tube keeps blowing off. Had both batteries disconected, now trouble.
geneb is offline  
post #2 of 2 Old 10-04-2010, 08:32 AM
Compression Ignition Addict
 
Join Date: Dec 2007
Posts: 6,204
Thanks: 7
Thanked 233 Times in 224 Posts
Mentioned: 6 Post(s)
Quoted: 75 Post(s)
Feedback Score: 3 reviews
Because of the CCV there is always oil in the IC tubes. Once this oil gets on the outside of the tube, between the boots & metal, it's hard to keep 'em on...


So, take some thinner, either, brakeclean, something that dries quickly and leaves no residue and do a really good job of removing any traces of oil from where they come together.

If dry & clean they shouldn't blow off again. The old timers will tell you to spray AquaNet on them to "glue" 'em down, again, shouldn't be necessary, but you could do that too

Also consider the CCV Mod to stop all that oil from getting in there in the first place....
NoRalPh is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome