PS 7.3L Wont Start after new fuel hoses - Ford Powerstroke Diesel Forum
User Tag List

LinkBack Thread Tools Display Modes
post #1 of 1 Old 03-26-2010, 12:13 AM Thread Starter Rookie
Join Date: Mar 2010
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
PS 7.3L Wont Start after new fuel hoses

I have a Ford F350 '95 7.3L International Diesel. The problem I seem to be running into is that I cant seem to get the bugger to start. So heres what I did.

I replaced the hoses connecting the fuel pump to the fuel filter on the top side of the engine and replaced the fuel filter. The hoses had were original (to my knowledge) and were cracked and leaking fuel all over my engine. I replaced them with no problem and mounted everything back up but now I cant seem to get the bugger to start.

I made sure all connections were made, their is fuel making it into the fuel filter and I was sure to prime it. I even did an Ethanol bomb to get the engine pumping fuel around. However I am not getting any fuel to the engine. The reason I say this is because if fuel was making it their, I'd see plumes of smoke coming out the stacks.

Also, I am getting some oil pressure, the normal when trying to crank the engine over.

The reason this is a 911 Urgent situation is because I need this beast for work on Saturday or I'm toast. Any help would be greatly appreciated.

darkmere is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome