Lost power driving then died - Ford Powerstroke Diesel Forum
User Tag List

LinkBack Thread Tools Display Modes
post #1 of 1 Old 03-23-2010, 06:28 PM Thread Starter
Powerstroke.org Rookie
Join Date: Dec 2009
Location: McCreary Manitoba
Posts: 28
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Lost power driving then died

I was driving along yesterday goin to town and i had the cruise set and all of the truck shifted down like i caught a head wind so i took the cruise off and the hit the throttle and the truck had no power at all. So i started to slow down to turn around to go home and when ilet off the throttle it just died. tried starting the truck and all it does it turn over no fire. the fuel pump is working cause i can here it and theres fuel at the filter on the motor what could be wrong? i took the truck to ford yesterday and there suppose to look at it tommorow morning. I was hoping someone would have an idea of what could be wrong so i can be prepared for what the dealer says. the truck is an 04 with the 6.0L any input is appreciated
Behr is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome