new engine noise, help diagnose please... 2004 6.0 - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 03-23-2010, 04:16 PM
Member
 

Join Date: Dec 2006
Posts: 46
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
new engine noise, help diagnose please... 2004 6.0

So, I just changed both of my Fuel filters four days ago and now I have a new sound coming from under the truck. It sounds like the Glow plugs are running all the time when the engine is running. I can't say that the two are related, but this is the only thing that has changed recently.

Back ground info... 2004 6.0 4x4. I found the the large filter on the frame rail was a little stubborn to remove and also reinstall. Is that common? It was so hard to get off and reinstall that I felt that I was going to crack the housing. I tightened it down as far as I felt comfortable and it looks like there is a very slight gap. I feel that it is is sealed against the rubber gasket and I don't hear any air being sucked in or diesel leaking from the filter housing.

Any ideas? I wanted to try the site prior to go to the dealership...
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 03-24-2010, 07:18 AM
Member
 

Join Date: Dec 2006
Posts: 46
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
any ideas???
Reply With Quote Quick reply to this message
  #3  
Old 03-24-2010, 07:35 AM
Tennessee Powerstrokes

 

Join Date: Mar 2009
Location: Lebanon TN
Posts: 2,830
Thanks: 0
Thanked 6 Times in 6 Posts
Feedback Score: 0 reviews
They are stubborn to both remove and install. Is the noise you hear while the truck is running, or is it evident only at start up? It is normal to hear a clickng sort of noise for a few seconds at key on for WTS, but anything else is not. I would check to make sure the filter on the frame is well seated before I took it in to the dealer
Reply With Quote Quick reply to this message
  #4  
Old 03-24-2010, 08:30 AM
Member
 

Join Date: Dec 2006
Posts: 46
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
As long as the engine is running I hear the noise. It sounds just like the glow plugs warming... Its odd.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 03:42 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors