no power rough idle ruined vacation - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 03-15-2010, 10:16 PM
Serving Our Country!
 

Join Date: Jan 2008
Location: Norman, Ok
Posts: 153
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
no power rough idle ruined vacation

i have an early '99 f-250 that has loss of power (pedal to the floor and it is slow to gain rpms and no acceleration even after rpms rise even a bit where the pedal to the floor got nothing), and a rough jerky idle a few times it died out. after stopping it runs fine for a bit then starts all over again. we were about 70 miles in to our trip to florida and had to turn around. any help would be appreciated we may still be able to take the trip if i get it fixed tomorrow a couple of thieves took the other car out i am waiting on a window to come in for that one
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 03-16-2010, 02:18 AM
Powerstroke.org Sponsor

 

Join Date: Jan 2009
Location: Hillsborough, NC
Posts: 1,011
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Have you changed the fuel filter recently? Have you changed the oil recently?
Reply With Quote Quick reply to this message
  #3  
Old 03-16-2010, 02:20 AM
Serving Our Country!
 

Join Date: Sep 2009
Posts: 931
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Send a message via AIM to 1tonpower
x2 on the fuel...
Reply With Quote Quick reply to this message
  #4  
Old 03-16-2010, 02:32 AM
scuffs *****

 

Join Date: Aug 2008
Location: Oakwood, OH
Posts: 5,272
Thanks: 0
Thanked 9 Times in 3 Posts
Feedback Score: 0 reviews
Send a message via AIM to Tyler
Change the CPS
Reply With Quote Quick reply to this message
  #5  
Old 03-27-2010, 02:45 PM
Serving Our Country!
 

Join Date: Jan 2008
Location: Norman, Ok
Posts: 153
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
found some bolts missing out of the turbo were the turbine and the compressor mate up 2 missing and 1 backed out all the way leaving 1 bolt to hold it all together also going to repack the hpop it has a small leak
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 11:45 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors