2001 7.3 barely runs - Ford Powerstroke Diesel Forum
User Tag List

LinkBack Thread Tools Display Modes
post #1 of 3 Old 03-03-2010, 09:57 AM Thread Starter
Powerstroke.org Rookie
Join Date: Nov 2008
Posts: 16
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
2001 7.3 barely runs

My truck has some serious issues. The other day I started idle fine then when I went to leave motor started skipping had no power ad basically would not go. It would stall out I would start it back up but ran real bad skipping like it was starving for fuel . Im sure it is getting fuel. I thought maybe I had water in the fuel because I let it sit for a while with a 1/4 tank an it did rain pretty hard the night before. Used gas cans to fill it to 3/4 and added some diesel 911 to the tank, emptied the fuel bowl put fresh diesel and 911 and installed new fuel filter. Now the truck starts hard I have to crank it a few time and mat the pedal. Sometimes it will idle like normal and just coughs every once in a while sometimes it wont stay idling and I have to work the pedal to keep it running. The check engine light will sometimes come on when it starts to sputter. If I go to put it in gear it will usually stall out, if it doesn't its a struggle to get it to move because it is sputtering so much and will buck and stall out. The water in fuel light has only come on once and then wet back off. If anyone has any ideas of what my problem may be I would greatly appreciate your input.
bassranger is offline  
Sponsored Links
post #2 of 3 Old 03-03-2010, 09:59 AM
Compression Ignition Addict
southern7.3's Avatar
Join Date: Apr 2007
Location: Barnwell/Bluffton, SC
Posts: 5,279
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 1 reviews
Send a message via AIM to southern7.3
need to get ya a code reader and see what comes up


2005 F350 King Ranch CC DRW Insight Leveled 4" MBRP Straight Pipe Tinted

'99 F250 - Sold
'99 Cummins - Sold
southern7.3 is offline  
post #3 of 3 Old 03-03-2010, 10:03 AM
Join Date: May 2008
Posts: 59
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
simple checks first.

make sure you have oil in your hpop
check your fuel pressure at fuel bowl.

I just went thru this and found that the fuel pressure regulator was completely open so no pressure could build up.
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome