6.0 running bad-good bad- no codes or smk - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 03-03-2010, 03:28 AM
Powerstroke.org Rookie
 

Join Date: Jan 2008
Posts: 21
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
6.0 running bad-good bad- no codes or smk

my 2003 6.0 is running terrible.
there are no codes and no smoke.
it sometimes runs great, then all of sudden, it just sounds like it is running on a couple of cyl. it will rev up but slowly and as if it is starved for fuel/air?

then it will go back to normal and all will be fine until it does it again. can last 5 minutes or 10minutes. at any speed.

anyone have any ideas before i start replacing parts?

thanks,

james
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 03-03-2010, 05:13 AM
Slacker



 

Join Date: Dec 2006
Location: Surprise, Arizona
Posts: 16,719
Thanks: 13
Thanked 11 Times in 9 Posts
Feedback Score: 4 reviews
I wouldn't just throw parts at it. Is it only when it is cold or a first start? Could just be stiction in the injectors, dirty EGR valve or that your turbo needs to be cleaned. Pull your EGR valve and clean it if you haven't done it in a while.
Reply With Quote Quick reply to this message
  #3  
Old 03-03-2010, 09:14 AM
Powerstroke.org Rookie
 

Join Date: Jan 2008
Posts: 21
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
hanks for your reply evil,
no it starts great sometimes. usually if i kill the engine when it is running poorly, it will not start. if i come back after an hour or so, it starts right up. as a side note, and i am not sure if it is related, but i did add diesel kleen (grey) and that is the day it started. could i have loosened up some crud and it is sporatically jamming the injectors? i have replaced fuel filters so far and did a really goood job cleaning my air filter.....i'll clean the egr valve and see what happens.
Reply With Quote Quick reply to this message
  #4  
Old 03-03-2010, 09:16 AM
Powerstroke.org Rookie
 

Join Date: Jan 2008
Posts: 21
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
confusing statement from my last post. after i added diesel kleen is when i started having the trouble.
Reply With Quote Quick reply to this message
  #5  
Old 03-03-2010, 10:27 AM
Slacker



 

Join Date: Dec 2006
Location: Surprise, Arizona
Posts: 16,719
Thanks: 13
Thanked 11 Times in 9 Posts
Feedback Score: 4 reviews
Keep us posted. Diesel kleen should help and not hurt performance.
Reply With Quote Quick reply to this message
  #6  
Old 03-03-2010, 04:49 PM
Powerstroke.org Rookie
 

Join Date: Jan 2008
Posts: 21
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
cleaned egr valve. still runs the same.
its weird. if i am going say 55 at 2000rpm and the engine starts it's little tricks again, it will stay roughly the same rpms and speed. just absolutely no power or acceleration. if i stop, it just takes forever to get to speed, but the rpms go up and down... just no power. makes no sense to me.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 02:59 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors