HELP! fuel leak? - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 02-28-2010, 08:09 AM
Powerstroke.org Rookie
 

Join Date: Feb 2010
Location: Canon City
Posts: 12
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Unhappy HELP! fuel leak?

I just bought a 95 F250 PSD. 4x4 W/Manual trans. Yesterday I started it and let it idle for around 20min. When I walked up to it, I noticed it had a puddle under it with a decent drip. It smells like fuel, its clear like fuel with a tiny bit of darker colored fluid in it (puddle was on concrete). Checked oil right away and no bubbles or fizz. Drives fine, only drips when running from back side of engine (cant see exactly where). Not sure where to look for problem. Thanks in advance for any advice.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 02-28-2010, 08:15 AM
duct tape & zip ties

 

Join Date: Jul 2006
Location: Willis, MI
Posts: 10,759
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Send a message via Yahoo to bigcountrysg
Sounds like you have a fuel leak in your engine valley. Look at the fuel filter.
Reply With Quote Quick reply to this message
  #3  
Old 02-28-2010, 08:34 AM
Powerstroke.org Rookie
 

Join Date: Feb 2010
Location: Canon City
Posts: 12
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Thanks for the reply. If I need to change the whole filter assembly will I have to re-prime the engine? I've also been buying some performance parts (nothing extreme) for this thing. Is there a particular fuel filter system you would recommend?
Reply With Quote Quick reply to this message
  #4  
Old 03-02-2010, 08:56 AM
Compression Ignition Addict
 

Join Date: Apr 2006
Posts: 326
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
not sure about your's but a while back mine started pouring fuel out the back..turned out that the line from the filter housing to the rear of the right side had a hole in it. seems that ford puts a clamp on this line that after a while, actually wears a hole in it. mine had a BIG hole, your's might just have a pin hole right now..it's worth a few minutes to check it out. if its ok..consider removing that clamp before it leaves ya stranded between here and there on a holiday with no parts store within 10 miles(been there..done that)
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 01:43 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors