***at my wits end*** - Ford Powerstroke Diesel Forum
User Tag List

LinkBack Thread Tools Display Modes
post #1 of 1 Old 01-14-2010, 04:52 AM Thread Starter
Powerstroke.org Rookie
Join Date: Jan 2010
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
***at my wits end***

2000 250 Superduty 7.3
This is what I'm up against...
Truck started having a "skip" with a very soft knock on the passenger side.
That "skip" turned into a knock and I did check the injectors...#3 was the only one that didn't make a difference....so I replaced it. While I was taking it out at idle it begin to blue smoke and act sluggish. Under pressure it cleared, but still with a "skip". Decided to go ahead and replace all injectors...after all it has 250,000 on it.
Still has a skip and knock...compression is good on all 8...gotta get this running
Any help would be appreciated
00sd250 is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome