95 PSD only running on one bank - - Ford Powerstroke Diesel Forum
User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 2 Old 03-29-2007, 06:47 PM Thread Starter
Powerstroke.org Rookie
 
Join Date: Mar 2007
Posts: 14
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
95 PSD only running on one bank -

OK - truck was at idle for about 45 min. As i walked to the truck to get in the motor stumbles and the continues to run rough - I have replaced the injectors (250,000 miles and have never been done to my knowlege) replaced under cover harness and repaired the other harnesses. Checked the valve cover gasket ---ok--- now what ???? IDM (was done 3 years ago)

HELP !!!!!
mike8349 is offline  
Sponsored Links
Advertisement
 
post #2 of 2 Old 03-30-2007, 04:34 AM
Compression Ignition Addict
 
Join Date: Apr 2006
Posts: 326
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I read an earlier post on here by someone who was experiencing the same problem...turned out to be the IDM..if it were me, and I'm notorious for this when I can, I'd hit a wreaking yard first to see if I could find one for the same model/year. To me, logic would dictate that they'd be the same. If you find one, swap it out, if it runs fine again, then, if you want, you can buy another from the dealer...just a thought...
howardtm is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome